AnsweredAssumed Answered

Unbricking S32K146

Question asked by sdrb@onet.eu on Jun 17, 2019
Latest reply on Jul 1, 2019 by sdrb@onet.eu

Hello,

 

I've got a development board with S32K146 which seems to be somehow corrupted. It worked correctly some time ago, but now I cannot reprogram it with S32 Design Studio for ARM. The result under S32DS is like this:

 

 

and it is not possible to program the MCU - because after click on Retry this window appear again and again. 

 

I suspect that something went wrong when I tried to program the MCU with copying some .srec file using Mass Storage programming method. 

 

I can see this board as a Mass Storage device under my Linux system, but I'm not sure if there is everything ok with the partitions presented on it:

 

# fdisk -l

Disk /dev/sdb: 968.8 MiB, 1015807488 bytes, 1983999 sectors
Disk model: FSL/PEMICRO MSD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0001022b

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 249855 247808 121M 6 FAT16

 

The suspected in following dump are size of the disk (968.8 MiB) and the partition size (121M). 

 

I tried to repair this board with Kinetis Recovery Utility under Windows but it showed the message that it is still trying to halt the processor and I should replug power supply. I replugged usb connector but the Kinetis Recovery Utility still shows this message.

 

I've seen somewhere that there are some partitions on the flash memory. Maybe this partitions are corrupted?

 

I've got Segger J-Link debugger also - maybe with it I could repair the board somehow?

Outcomes