AnsweredAssumed Answered

Installing GStreamer on I.MX8QM

Question asked by Mustafa Ozcelikors on Aug 27, 2018
Latest reply on Nov 9, 2018 by Dan Searles

Hi all,

 

I am trying to figure out how to properly install gstreamer on imx8qm-mek (for a qt app to use).
I am using the morty branch (beta2 release) for imx8qm.
More precisely Linux L4.9.51 for i.MX 8QuadMax Beta2 and i.MX 8QXPlus Beta  from Alpha / Beta BSPs for Microprocessors|NXP . And I am building an image with weston/wayland.
I have the following in my image recipe:

IMAGE_INSTALL_append = " qtmultimedia \

gstreamer1.0 \

gstreamer1.0-plugins-base \

gstreamer1.0-plugins-bad \

packagegroup-gsl-gstreamer1.0 \

gstreamer1.0-plugins-base-meta \

gstreamer1.0-plugins-bad-meta \
gstreamer1.0-plugins-good-meta \
libnl \

libnl-genl \

qtbase-plugins \

qtmultimedia-plugins \

qtimageformats-plugins \

"


When I create the image, qt media player app (which works in Raspberry Pi) complains:

 

====== BEEP: 4.3.3 build on Aug 13 2018 18:58:20. ======
Core: AAC decoder Wrapper build on Dec 7 2017 18:13:51
file: /usr/lib/imx-mm/audio-codec/wrap/lib_aacd_wrap_arm_elinux.so.3
Warning: "No decoder available for type 'video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)avc, width=(int)1280, height=(int)720, framerate=(fraction)25/1, codec_data=(buffer)014d401fffe1001c674d401fe8802802dd80b501010140000003004000000c83c60c448001000468ebef20, pixel-aspect-ratio=(fraction)1/1, interlace-mode=(string)progressive, profile=(string)main, level=(string)3.1'."
CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.09.00_ARMV8 build on Sep 20 2017 15:02:50.
====== BEEP: 4.3.3 build on Aug 13 2018 18:58:20. ======
Core: MP3 decoder Wrapper build on Dec 7 2017 18:14:28
file: /usr/lib/imx-mm/audio-codec/wrap/lib_mp3d_wrap_arm_elinux.so.3
CODEC: BLN_MAD-MMCODECS_MP3D_ARM_02.13.00_ARMV8 build on Feb 13 2017 19:47:36.
====== AIUR: 4.3.3 build on Aug 13 2018 18:58:16. ======
Core: MPEG4PARSER_06.12.12 build on Oct 27 2017 02:58:02
file: /usr/lib/imx-mm/parser/lib_mp4_parser_arm_elinux.so.3.2
------------------------
Track 00 [video_0] Enabled
Duration: 0:03:58.600000000
Language: und
Mime:
video/x-h264, parsed=(boolean)true, alignment=(string)au, stream-format=(string)avc, width=(int)1280, height=(int)720, framerate=(fraction)25/1, codec_data=(buffer)014d401fffe1001c674d401fe8802802dd80b501010140000003004000000c83c60c448001000468ebef20
------------------------
------------------------
Track 01 [audio_0] Enabled
Duration: 0:03:58.608244000
Language: eng
Mime:
audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)44100, bitrate=(int)0, stream-format=(string)raw, codec_data=(buffer)1210
------------------------

Furthermore, I get the following (which I was able to get rid off by removing gst- plugins (not the gstreamer1.0 ones)

(gst-plugin-scanner:9753): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-1.0/libgstqt5videosink.so': libXdamage.so.1: cannot open shared object file: No such file or directory

Now, I noticed that in the master branch of meta-freescale, there are some new recipes under gstreamer folder, namely: gstreamer1.0-plugins-imx gstreamer1.0_1.12.imx. I am unable to integrate these because of the syntax changes in Yocto from morty to rocko. Are these packages important. Is it sufficient to have morty release for a complete gstreamer install?

Any suggestions are highly appreciated.

Outcomes