AnsweredAssumed Answered

Amazon-FreeRTOS with Emwin on LPC54628

Question asked by Raymond Chin on Aug 3, 2018
Latest reply on Aug 8, 2018 by Victor Jimenez

Hi..

Has anyone had any issues with running Amazon-FreeRTOS with EMWIN on a LPCxpresso54628 board?

 

I am using MCUExpresso 10.2.1, with the 2.4.1 SDK for the LPCxpresso54628 board.

I ran the LPC54608 Emwin touch and draw example, running on the older FreeRTOS, on the LPCxpresso54628 board and it ran fine.

 

And when I tried porting the code over to the Amazon-FreeRTOS, I get the semihost_hardfault on the LPCxpresso54628 board .  I tracked it down to the execution of GUI_Init().  I also noticed that with Amazon-FreeRTOS, the heap memory becomes 100% full, unlike the older version of FreeRTOS - this is also a symptom of the Amazon-FreeRTOS examples.  I played with moving some of the code/data to external SDRAM using the linker, but to no success..except for harder crashes, in which I have to restart MCUExpresso, and power down the development board.

 

Does anyone have any insight to a fix?

 

Regards,

Outcomes