AnsweredAssumed Answered

Complete Boot from QSPI nor flash for imx6ull and MFG(4.9.11) tool support to flash u-boot, kernel,dtb and rootfs

Question asked by jaya b c on Jul 6, 2018
Latest reply on Jul 10, 2018 by jaya b c

Hi all,
>>     I am using imx6ull nxp board. In the reference board 32MB(256Mb) QSPI nor flash is used. Is it possible boot from QSPI by flashing complete u-boot,kernel, dtb and   
        rootfs to QSPI nor flash?
>>  I have tried flashing using mfg tool(4.9.11), but I am able to flash only U-boot(see below logs).

 

        U-Boot 2017.03-nxp/imx_v2017.03_4.9.11_1.0.0_ga+ga2fea67 (Jul 06 2018 - 16:01:17 +0530)

        CPU:   Freescale i.MX6ULL rev1.0 at 396MHz
        CPU:   Commercial temperature grade (0C to 95C) at 46C
        Reset cause: WDOG
        Model: Freescale i.MX6 ULL 14x14 EVK Board
         Board: MX6ULL 14x14 EVK
         DRAM:  512 MiB
          MMC:   FSL_SDHC: 0, FSL_SDHC: 1
        SF: Detected n25q256 with page size 256 Bytes, erase size 4 KiB, total 32 MiB
        Display: TFT43AB (480x272)
        Video: 480x272x24
         In:    serial
         Out:   serial
        Err:   serial
        Net:   eth1: ethernet@020b4000 [PRIME], eth0: ethernet@02188000
        Normal Boot
        Hit any key to stop autoboot:  0
        Card did not respond to voltage select!
        mmc_init: -95, time 47
        Card did not respond to voltage select!
        mmc_init: -95, time 47
        MMC: no card present
         mmc_init: -123, time 2
       Booting from net ...
      ethernet@020b4000 Waiting for PHY auto negotiation to complete......... TIMEOUT !
      Could not initialize PHY ethernet@020b4000
      BOOTP broadcast 1
      BOOTP broadcast 2
      BOOTP broadcast 3
      BOOTP broadcast 4

 

>> Is mfg tool(4.9.11) supports to flash complete OS(u-boot,kernel, dtb and rootfs) to QSPI nor flash?

 

 >> OR We need to use QSPI nor flash only for u-boot? The kernel, dtb rootfs should be loaded to other boot device?

 

Eagerly waiting for response. Please help if someone already worked on it.

 

Thanks in advance
Jaya

Outcomes