AnsweredAssumed Answered

MCUXpresso Ubuntu 18.04 Install - Dependency Problems

Question asked by Andrew Murfin on Jun 6, 2018
Latest reply on Jun 7, 2018 by Andrew Murfin

Hello.  I'm attempting to install MCUXpresso onto Ubuntu 18.04.  As per the current installation guide for Ubuntu, I did chmod to make the .deb.bin file executable, and executed it as root.  Here are the results:  

 

root@andys_ubuntu_external:/home/amurfin/Downloads# ./mcuxpressoide-10.2.0_759.x86_64.deb.bin
Verifying archive integrity... All good.
Uncompressing mcuxpressoide installer 100%
Installing...
(Reading database ... 169414 files and directories currently installed.)
Preparing to unpack JLink_Linux_x86_64.deb ...
Removing /opt/SEGGER/JLink ...
Unpacking jlink (6.32.2) over (6.32.2) ...
Setting up jlink (6.32.2) ...
Selecting previously unselected package mcuxpressoide.
(Reading database ... 169414 files and directories currently installed.)
Preparing to unpack mcuxpressoide-10.2.0_759.x86_64.deb ...
Unpacking mcuxpressoide (10.2.0) ...
dpkg: mcuxpressoide: dependency problems, but configuring anyway as you requested:
mcuxpressoide depends on libncurses5:i386.
mcuxpressoide depends on libusb-1.0-0-dev; however:
Package libusb-1.0-0-dev is not installed.
mcuxpressoide depends on dfu-util; however:
Package dfu-util is not installed.
mcuxpressoide depends on libwebkitgtk-1.0-0; however:
Package libwebkitgtk-1.0-0 is not installed.

Setting up mcuxpressoide (10.2.0) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
mcuxpressoide
0 upgraded, 0 newly installed, 1 to remove and 35 not upgraded.
After this operation, 1,389 MB disk space will be freed.
(Reading database ... 185214 files and directories currently installed.)
Removing mcuxpressoide (10.2.0) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
root@andys_ubuntu_external:/home/amurfin/Downloads#

 

It seems like the problem comes with the dependency problems.  The installation guide says all necessary packages should be installed automatically.  I am currently attempting to install the packages one-by-one anyway, if I can find the right versions.  Please let me know if this is the correct route or if this is a known issue.

 

Thanks

 

-Andy

Outcomes