AnsweredAssumed Answered

How to start linux after enabeling RPMsg in Devicetree

Question asked by Erik Friedel on May 30, 2018
Latest reply on Jun 24, 2018 by Erik Friedel

Hi there

 

I have got an iMX7s on custom board with 512MB Ram. I successfully run the hello_world example and now I am trying to get the pingpong example to work. On the M4 side there are no problems. I can boot and it shows:

   RPMSG PingPong FreeRTOS RTOS API Demo...
   RPMSG Init as Remot

But on the Linux side there are a few problems:

If I don't enable rpmsg in the devicetree I can boot and load the pingpong module using modprobe imx_rpmsg_pingpong. Additionaly rpmsg is shown in /sys/bus and /sys/module/ . But nothing else happens.

If I set rpmsg in the devicetree to "okay" I just see this:

   Starting kernel ...

   Uncompressing Linux... done, booting the kernel.

 

Things that I've changed so far:

   - obviously modifying the DT

         - set rpmsg to "ok"

         - set usable memory

         / {

          memory {
          linux,usable-memory = <0x80000000 0x1ff00000>;

          }

          }

   - changing the vring in the Linux kernel in imx_rpmsg.c  from BFFF0000 --> 9FFF0000 (and BFFF8000 --> 9FFF8000)

   - changing the vring in FreeRTOS in platform_info.c the same way

   - RPMsg and Pingpong are enabled in the Kernel

 

Please help

 

Erik

Outcomes