AnsweredAssumed Answered

Idle state of RTS in RS-485 mode on IMX6

Question asked by Jeff Hunsinger on Dec 4, 2017
Latest reply on Dec 4, 2017 by igorpadykov

I activated RS-485 mode on the IMX6UL using UART7 and the RTS pin transitions as expected when I have the port open. However, when I close the port, the pin goes high even though I have it configured to be low when not transmitting. There is an external pull-up on this pin because it is used to configure the IMX6UL at reset.

 

Is there a way to have the pin drive low by default when the UART is not open?

 

I am using the LCD_DATA06_DTE_RTS pin with the UART in DCE mode.

I use the following to enable RS-485 mode in the Linux driver:

 

rs485conf.flags |= SER_RS485_ENABLED;
rs485conf.flags |= (SER_RS485_RTS_ON_SEND);
rs485conf.flags &= ~(SER_RS485_RTS_AFTER_SEND);

ioctl(fd, TIOCSRS485, &rs485conf);

 

Thank you,

Jeff

Outcomes