AnsweredAssumed Answered

no startup files with new C++ lpc54114 sdk project

Question asked by klausrschambeck on Jul 26, 2017
Latest reply on Aug 9, 2017 by Carlos_Mendoza

for test purpose i imported the "C" hello world sdk demo app for the lpc54114 sdk 2.2.1 and everything seems to work ... it prints "hello world and somehow also echoes input strings

 

since this is a "C" project and i need a "C++" framework i was really not into converting it into "C++" because of all the clumsy C-compiler and C-linker settings transfer into the C++ equivalents and a bunch more ... did it successful with the lpcopen uart sample

 

so, i tried to create a brand new mcuxpresso sdk based project and only changed the project type from "C" compiler setting to "C++" and included all drivers, otherwise i left the defaults ... it created ... it compiles to a size of, see below :

 

text data bss dec hex filename
200 0 8220 8420 20e4 lpc54114_sdk_main.axf

 

furthermore the startup directory is empty and no startup_lpc5411x.c  / cpp file can be found

 

am i doing something wrong ...  i thought i followed the following tutorial as much as possible

 

MCUXpresso IDE - Creating New SDK Project|NXP 

 

how can this be solved ???

 

what did i do wrong ???

 

thanks and cheers efiLabs

 

meanwhile i tried it also with the latest mcuxpresso 10.0.2 ... same thing

 

one more weird thing, despite an empty startup directory ... i compared the hello world example directory tree to the one from the new C++ project and noticed the following ... the new C++ project has no board folder and this missing board folder content is now inside the source folder ... also the board, clock-config and pin_mux files differ between the hello world example and the create new C++ project ... maybe this helps, maybe not

in the meantime i upgraded the hello world "C" example to "C++" and it still works, so i can somehow continue my sdk evaluation 

 

it would be nice if the new C++ project would produce a working framework based upon the new sdk feature

 

what i also noticed is the following : upon installing an sdk it doesn't seem possible to create an lpcopen project anymore ... unless you remove the sdk zip file form the "SDKPackages" folder

 

any answer to this help cry would be highest appreciated

 

Building target: lpc54114_sdk_main.axf
Invoking: MCU C++ Linker
arm-none-eabi-c++ -nostdlib -L"/usr/local/e_drive/Baja/code-arm/cortex_54114/lpc54114_sdk_main/libs" -Xlinker -Map="lpc54114_sdk_main.map" -Xlinker --gc-sections -Xlinker -print-memory-usage -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=hard -mthumb -T lpc54114_sdk_main_Debug.ld -o "lpc54114_sdk_main.axf" ./utilities/fsl_debug_console.o ./source/board.o ./source/clock_config.o ./source/lpc54114_sdk_main.o ./source/pin_mux.o ./drivers/fsl_adc.o ./drivers/fsl_clock.o ./drivers/fsl_common.o ./drivers/fsl_crc.o ./drivers/fsl_ctimer.o ./drivers/fsl_dma.o ./drivers/fsl_dmic.o ./drivers/fsl_dmic_dma.o ./drivers/fsl_flashiap.o ./drivers/fsl_flexcomm.o ./drivers/fsl_fmeas.o ./drivers/fsl_gint.o ./drivers/fsl_gpio.o ./drivers/fsl_i2c.o ./drivers/fsl_i2c_dma.o ./drivers/fsl_i2s.o ./drivers/fsl_i2s_dma.o ./drivers/fsl_inputmux.o ./drivers/fsl_mrt.o ./drivers/fsl_pint.o ./drivers/fsl_power.o ./drivers/fsl_reset.o ./drivers/fsl_rtc.o ./drivers/fsl_sctimer.o ./drivers/fsl_spi.o ./drivers/fsl_spi_dma.o ./drivers/fsl_usart.o ./drivers/fsl_usart_dma.o ./drivers/fsl_utick.o ./drivers/fsl_wwdt.o ./CMSIS/system_LPC54114_cm4.o -lfsl_power_cm4_hard
Memory region Used Size Region Size %age Used
PROGRAM_FLASH: 200 B 256 KB 0.08%
SRAM1: 8220 B 64 KB 12.54%
SRAM0: 0 GB 64 KB 0.00%
SRAMX: 0 GB 32 KB 0.00%
SRAM2: 0 GB 32 KB 0.00%
/usr/mcuxpresso/mcuxpressoide-10.0.0_344/ide/tools/bin/../lib/gcc/arm-none-eabi/5.4.1/../../../../arm-none-eabi/bin/ld: warning: cannot find entry symbol ResetISR; defaulting to 00000000
Finished building target: lpc54114_sdk_main.axf

make --no-print-directory post-build
Performing post-build steps
arm-none-eabi-size "lpc54114_sdk_main.axf"; # arm-none-eabi-objcopy -v -O binary "lpc54114_sdk_main.axf" "lpc54114_sdk_main.bin" ; # checksum -p LPC54114J256 -d "lpc54114_sdk_main.bin";
text data bss dec hex filename
200 0 8220 8420 20e4 lpc54114_sdk_main.axf

Outcomes