AnsweredAssumed Answered

I have this makefile project, which I want to debug in MCUXpresso, but it does not work.

Question asked by vespaman on Jun 7, 2017
Latest reply on Jun 9, 2017 by LPCX presso support

I have this makefile project, which I want to debug in MCUXpresso, but it does not work.

If I select it the normal way, by choosing File->Import->C/C++->Existing Code as Makefile Project, everything seams to work, but I cannot select debug from the Quickstart page, or clicking the blue debug button; nothing happens when do.

Also, I get a null pointer Java exception, when I select MCU in the project settings, this might not be an issue, since it is all setup in the makefile anyways, but I thought I should mention it.

 

If I instead use the Quick start and use "Import Projects from the filesystem", I have the same issue I think. However, before I set-up the build setting correctly, I got a selection box asking for the debugger interface (jlink in my case), and binary. After I built target, nothing happens when I press Debug in the Quick start panel, also nothing when I press the blue bug.

 

How am I supposed to import a makefile project? I never experienced this kind of issues with KDS, or other (code sourcery) eclipse environments...

My MCU is a K64, should this matter.

 

Edit: I have now started from scratch again, and my conclusion is that one should not use import from the quick start panel, it only seams to accept previously created eclipse project files, not makefile projects.

Outcomes