AnsweredAssumed Answered

Expert Mode missing in Component Configuration - PE

Question asked by Robert Lewis on May 31, 2017
Latest reply on Jun 1, 2017 by Erich Styger

I have searched for two days on how to add back Expert mode to the component inspector but haven't found a way. I know about the project settings but I am totally missing the Expert entry. I have Basic and Advanced, but from other posts they indicate we need Expert to configure the MCG USB clock. I have uninstalled, and re-installed many time with different patches, but none have worked.

 

I have KDS v3.2, with PE update 3.0.2b, and Component Development Environment 1.8.0.RT7, with sdk v1.3. I have also tried going back all the way to KDS v2.0 and still it does not appear. I know this worked fine with codewarrior but I have not used PE for about three years and want to use it now.

 

Is this something disabled to force a termination of PE? I know that NXP is dropping support of PE and sdk v2.2 has no integration with PE.

 

Would it be best to revert to an eclipse based system or does anyone know how to get this functionality to work? I know that Erich on McuOnEclipse uses this without problem. Do we have to by a Component Development License in order to get back this mode? ($995 US).

 

On this site there is a few posts that say Expert Mode was merged with Advanced mode in Codewarrior 10.6, "In the CodeWarrior 10.6, this has been changed and the Advanced and Expert options are merged into one Advanced view mode so you will see there all available settings."

 

The problem is I don't see all available settings. I can't change or access the USB clock system and am getting a warning saying the clock is not set. I can go into the SIM registers and manually check this but am concerned that other things may not be set correctly as well. Is this just a bug, if so what is the work around?

 

Thanks for any help.


Robert

Outcomes