AnsweredAssumed Answered

Debug does not succeed unless I start RedlinkServ manually. (RedProbe +)

Question asked by Mitchell Jones on Aug 30, 2016
Latest reply on Sep 15, 2016 by LPCX presso support

Hello Community, I'm new here, however I have been searching online for solutions and have attempted several things and nothing has worked yet.

 

Symptoms:

  • When I launch debug LPCXpresso does not find "an emulator" (debugger). The first time or two I launched it a Windows firewall dialog came up, I have allowed it and verified that the entry is in the firewall. (it appears on the inbound side).
  • If I launch the redlinkserv.exe executable from the command line, then attempt debug from lpcxpresso, my probe is found and everything works as expected.

It appears to me that lpcxpresso is somehow failing to start the server. The issue with my workaround is that once I stop the debug it kills the redlinkserv process and I have to relaunch it each time I run debug. I don't want to have to do that.

 

Thanks in advance!

 

I'm running LPCXpresso v8.2.0 [Build 647] [2016-07-18] 

Screenshot of the issue.

 

The less than ideal work around I have for now.

Outcomes