AnsweredAssumed Answered

imx6 - Can't download image to emcc 5.0 by mfg after change uImage

Question asked by nice hsieh on Jun 24, 2016
Latest reply on Feb 14, 2017 by he he

Hi everyone,

   Recently our custom i.mx6Q board wanna using eMMC 5.0 instead eMMC 4.4, so we need rebuild uImage for mfgtool. (Mfgtools-Rel-13.01_00_ER_MX6Q_UPDATER)

   We tried Dan's suggestion to rebuild uImage, (thanks for Dan, Here is before discuss info https://community.nxp.com/thread/397166)

   (add "CONFIG_SWITCH=y" in arch/arm/configs/imx6_updater_defconfig ref:https://community.nxp.com/thread/307477)

   $ make imx6_updater_defconfig

   $ make uImage

and use new uImage to replace the orginial one in mfgtool.

It looks better, and solved the problem about kernel panic.

 

But I got new error msg as below

U-Boot 2009.08 (Jun 02 2013 - 23:06:16)

CPU: Freescale i.MX6 family TO1.5 at 792 MHz

...

...

...                                                                                                                   

Board: i.MX6Q-SABRESD: RevC Board: 0x63315 [POR ]                                                                                                                

Boot Device: SD

I2C:   ready

DRAM:   1 GB

MMC:   FSL_USDHC: 0,FSL_USDHC: 1,FSL_USDHC: 2,FSL_USDHC: 3                   

Using default environment

In:    serial

Out:   serial

Err:   serial

Net:   got MAC address from IIM: 00:00:00:00:00:00

FEC0 [PRIME]

Hit any key to stop autoboot:  0

## Booting kernel from Legacy Image at 10800000 ...

   Image Name:   Linux-3.0.35-06527-gb727aa3-dirt

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    3196924 Bytes =  3 MB

   Load Address: 10008000

   Entry Point:  10008000

   Verifying Checksum ... OK

## Loading init Ramdisk from Legacy Image at 10c00000 ...

   Image Name:   uboot initramfs rootfs

   Image Type:   ARM Linux RAMDisk Image (gzip compressed) 

   Data Size:    4543831 Bytes =  4.3 MB

   Load Address: 00000000

   Entry Point:  00000000

   Verifying Checksum ... OK

   Loading Kernel Image ... OK

OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Linux version 3.0.35-06527-gb727aa3-dirty (nice@nice-zx530) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #659 SMP PREEMPT Fri Jun 17 19:03:38 CST 2016

CPU: ARMv7 Processor [412fc09a] revision 10 (ARMv7), cr=10c53c7d         

CPU: VIPT nonaliasing data cache, VIPT aliasing instruction cache

Machine: Freescale i.MX 6Quad/DualLite/Solo Sabre-SD Board

Memory policy: ECC disabled, Data cache writealloc

CPU identified as i.MX6Q, unknown revision

PERCPU: Embedded 7 pages/cpu @8185d000 s5184 r8192 d15296 u32768                 

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 260096

Kernel command line: console=ttymxc0,115200 rdinit=/linuxrc enable_wait_mode=off

PID hash table entries: 4096 (order: 2, 16384 bytes)

Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)

Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)

Memory: 1024MB = 1024MB total

Memory: 1028628k/1028628k available, 19948k reserved, 0K highmem       

Virtual kernel memory layout:

    vector  : 0xffff0000 - 0xffff1000   (   4 kB)

    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)

    DMA     : 0xfbe00000 - 0xffe00000   (  64 MB)

    vmalloc : 0xc0800000 - 0xf2000000   ( 792 MB)

    lowmem  : 0x80000000 - 0xc0000000   (1024 MB)

    pkmap   : 0x7fe00000 - 0x80000000   (   2 MB)

    modules : 0x7f000000 - 0x7fe00000   (  14 MB)

      .init : 0x80008000 - 0x8003b000   ( 204 kB)

      .text : 0x8003b000 - 0x805bc644   (5638 kB)

      .data : 0x805be000 - 0x8060bd60   ( 312 kB)

       .bss : 0x8060bd84 - 0x80638c28   ( 180 kB)

SLUB: Genslabs=13, HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1

Preemptible hierarchical RCU implementation.

...

...

...                                                                                                          

print_constraints: PFUZE100_SW1A: 300 <--> 1875 mV at 1300 mV

print_constraints: PFUZE100_SW1B: 300 <--> 1875 mV at 300 mV

print_constraints: PFUZE100_SW1C: 300 <--> 1875 mV at 1300 mV

print_constraints: PFUZE100_SW2: 800 <--> 3950 mV at 3300 mV

print_constraints: PFUZE100_SW3A: 400 <--> 1975 mV at 1500 mV

print_constraints: PFUZE100_SW3B: 400 <--> 1975 mV at 1500 mV

print_constraints: PFUZE100_SW4: 800 <--> 3950 mV at 3150 mV

print_constraints: PFUZE100_SWBST: 5000 <--> 5150 mV at 5000 mV

print_constraints: PFUZE100_VSNVS: 1200 <--> 3000 mV at 1800 mV

print_constraints: PFUZE100_VREFDDR: at 750 mV

print_constraints: PFUZE100_VGEN1: 800 <--> 1550 mV at 1500 mV       

print_constraints: PFUZE100_VGEN2: 800 <--> 1550 mV at 1500 mV

print_constraints: PFUZE100_VGEN3: 1800 <--> 3300 mV at 2500 mV

print_constraints: PFUZE100_VGEN4: 1800 <--> 3300 mV at 1800 mV

print_constraints: PFUZE100_VGEN5: 1800 <--> 3300 mV at 2800 mV

print_constraints: PFUZE100_VGEN6: 1800 <--> 3300 mV at 3300 mV

imx-ipuv3 imx-ipuv3.0: IPU DMFC NORMAL mode: 1(0~1), 5B(4,5), 5F(6,7)

imx-ipuv3 imx-ipuv3.1: IPU DMFC NORMAL mode: 1(0~1), 5B(4,5), 5F(6,7)

Advanced Linux Sound Architecture Driver Version 1.0.24.

Bluetooth: Core ver 2.16

NET: Registered protocol family 31                                                                                                                                    

Bluetooth: HCI device and connection manager initialized

Bluetooth: HCI socket layer initialized                                                                                                                               

Bluetooth: L2CAP socket layer initialized

Bluetooth: SCO socket layer initialized                                                                                                                               

i2c-core: driver [max17135] using legacy suspend method

i2c-core: driver [max17135] using legacy resume method

Switching to clocksource mxc_timer1                     

Clockevents: could not switch to one-shot mode:

Clockevents: could not switch to one-shot mode:

Clockevents: could not switch to one-shot mode:

Clockevents: could not switch to one-shot mode: dummy_timer is not functional.

dummy_timer is not functional.                                                                                                                                       

dummy_timer is not functional.                                                                                                                                       

Could not switch to high resolution mode on CPU 1                                                                                                            

Could not switch to high resolution mode on CPU 2

Could not switch to high resolution mode on CPU 3

dummy_timer is not functional.                                                                                                                                       

Could not switch to high resolution mode on CPU 0

NET: Registered protocol family 2                                                                                                                                     

...

...

...                                                       

nice_csd.structure=3                                                                                                                                                  

nice_ext_csd.raw_ext_csd_structure=2   

nice_ext_csd.rev=7

nice_ext_csd.rev=7

Bluetooth: RFCOMM socket layer initialized

Bluetooth: RFCOMM ver 1.11                                                                                                                                            

Bluetooth: BNEP (Ethernet Emulation) ver 1.3

mmc0: new high speed DDR MMC card at address 0001

mmcblk0: mmc0:0001 R1J56L 13.7 GiB            

mmcblk0boot0: mmc0:0001 R1J56L partition 1 4.00 MiB

mmcblk0boot1: mmc0:0001 R1J56L partition 2 4.00 MiB

mmcblk0: unknown partition table                                                                                                                                     

Bluetooth: BNEP filters: protocol multicast  

Bluetooth: HIDP (Human Interface Emulation) ver 1.2

VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4

mmcblk0boot1: unknown partition table                 

Bus freq driver module loaded                                                                                                                                         

Bus freq driver Enabled                                                                                                                                               

mmcblk0boot0: unknown partition table      

mxc_dvfs_core_probe                                                                                                                                                   

DVFS driver module loaded                                                                                                                                             

regulator_init_complete: PFUZE100_VGEN6: incomplete constraints, leaving on

regulator_init_complete: PFUZE100_VGEN3: incomplete constraints, leaving on

regulator_init_complete: PFUZE100_VGEN2: incomplete constraints, leaving on

regulator_init_complete: PFUZE100_VGEN1: incomplete constraints, leaving on

regulator_init_complete: SPKVDD: incomplete constraints, leaving on

snvs_rtc snvs_rtc.0: setting system clock to 1970-01-01 00:00:00 UTC (0)

Freeing init memory: 204K                                                                                                                                             

Starting UTP                                                                                                                                                          

ln: /etc/mtab: File exists                                                                                                                                            

disable turn off display                                                                                                                                              

Starting the hotplug events dispatcher udevd

udevd (2003): /proc/2003/oom_adj is deprecated, please use /proc/2003/oom_score_adj instead.

Synthesizing initial hotplug events                                                                                                                                   

g_file_storage gadget: high speed config #1

uuc 0.4 [built May 23 2013 23:59:39]                                                                                                                                  

UTP: Waiting for device to appear                                                                                                                                     

UTP: file/device node /dev/utp already exists

cpu_id is 0                                                                                                                                                           

UTP: received command '$ dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16'

UTP: executing "dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16"

16+0 records in                                                                                                                                                       

16+0 records out                                                                                                                                                      

8192 bytes (8.0KB) copied, 0.013654 seconds, 585.9KB/s

UTP: sending Success to kernel for command $ dd if=/dev/zero of=/dev/mmcblk0 bs=512 seek=1536 count=16.

utp_poll: pass returned.                                                                                                                                              

UTP: received command '$ echo 1 >mmc0: DO NOT switch the partitions that used to be

accessed in OS layer HERE. please following the

guidance of Documentation/mmc/mmc-dev-parts.txt.

/sys/devices/platform/sdhci-esdhc-imx.3/mmc_host/mmc0/mmc0:0001/boot_config'

UTP: executing "echo 1 > /sys/devices/platform/sdhci-esdhc-imx.3/mmc_host/mmc0/mmc0:0001/boot_config"

sh: write error: Invalid argument                                                                                                                                     

UTP: sending Non-success to kernel for command $ echo 1 > /sys/devices/platform/sdhci-esdhc-imx.3/mmc_host/mmc0/mmc0:0001/boot_config.                                

utp_poll: exit with status 256

[stop here]

 

 

Here is my environment in uboot.

bootargs=console=ttymxc0,115200 rdinit=/linuxrc enable_wait_mode=off

bootcmd=bootm 0x10800000 0x10c00000

bootdelay=0

baudrate=115200

ipaddr=192.168.1.103

serverip=192.168.1.101

netmask=255.255.255.0

loadaddr=0x10800000

rd_loadaddr=0x10c00000

netdev=eth0

ethprime=FEC0

uboot=u-boot.bin

kernel=uImage

stdin=serial

stdout=serial

stderr=serial

ethact=FEC0

 

We use emmc to boot up on our board by mfgtool to downloag android image.

Could you give me some advice about this problem ?

Thanks.

Outcomes