AnsweredAssumed Answered

FreeRTOS LwIP SDK v2.0.0 tpcipecho demo crash

Question asked by Wilco --- on May 26, 2016
Latest reply on Apr 16, 2018 by Paul van Oppen

Dear all,

 

I'm using the K64 Tower board and downloaded the SDK2.0.0. Then I started to run the tcpipecho server demo which uses FreeRTOS and LwIP in KDS. It runs fine for some time (something like a few minutes). I can connect/disconnect to it and echo some text. But after that it crashes (HardFault) (most of the time LwIP's memp_alloc() cannot allocate memory).

 

I tried a lot to figure out what could cause it. Enabled memory check, increased pbuf size and chain, tried C malloc, increased FreeRTOS heap moved it to SRAM-H .... But nothing helps.

 

Then I started to download the SDK again but for IAR and downloaded the IAR demo version. Still the same, after a some time it crashes.

 

- Does someone has the same experience and knows what the problem is?

- Is there a very stable working example for FreeRTOS in combination with LwIP (preferable a K64 client demo)?

- Does someone has tips to let it work?

Outcomes