AnsweredAssumed Answered

Cannot get imxg2dvideosink to work

Question asked by Stefan Ott on May 19, 2016
Latest reply on May 19, 2016 by igorpadykov


We are having an issue with an i.MX6 board trying to play a video. The system is running Ubuntu "oneiric" and comes with gstreamer-0.10. So far we have been using the mfw_v4lsink module but somehow a couple of pixels get cut off around the edge, thus we tried to upgrade to gstreamer-1.x which fixed the same issue on another i.MX6 system. Our gstreamer pipeline looks something like this:

gst-launch-1.0 udpsrc [..] ! rtpmp4vdepay ! mpeg4videoparse ! imxvpudec ! progressreport update-freq=1 ! imxg2dvideosink use-vsync=false sync=false

Unfortunately the new imxg2dvideosink module seems unhappy:

Setting pipeline to PAUSED ...

g2d_alloc: alloc memory fail with size 16!

ERROR: Pipeline doesn't want to pause.

Setting pipeline to NULL ...

Freeing pipeline ...

 

Some more details about the system:

  • The board is an iW-RainboW-G15M from iWave
  • It's running kernel 3.0.35-2666-gbdde708
  • The vivante libraries we tried to use are from version 3.10.17-1.0.2
  • The gstreamer version we tried is 1.6.4

 

Does anyone have an idea about why this might be failing?

Outcomes