AnsweredAssumed Answered

Performance issue with weston 1.8/1.9 on IMX6Q

Question asked by Dominique Bureau on May 11, 2016
Latest reply on Jul 20, 2017 by mrleo

I'm currently in the process of updating our board's Yocto bsp (from Daisy to Jethro) and noticed a performance decrease in Weston using fbdev-backend. The simplest way I found to reproduce the issue is by using the weston-simple-egl example. I used to get a solid 60 fps with double buffering, but can't manage to get more than 35 fps now (39 by enabling gal2d).

 

By pulling the old weston-1.6 recipes, I was able to get a bit more framerate (50fps with double-buffering), but I still can't achieve the 60fps we were previously capable of. The behaviour was observed on our custom board, and also on our development boards which are plain Boundary Devices Sabre-Lite, both running 1280x720p @ 32bpp.

 

I suspect something has changed in Weston > 1.6 and/or the gpu-viv drivers (now a modular galcore.ko). Also, just to be sure this was not something new introduced in the community repo only, I rebuilt the fsl-arm-yocto-bsp with our kernel and ended up with the same results.

 

Anybody else has this issue?

 

For reference, here are the setup:

Old configuration (60 fps):

- Yocto Daisy (meta-fsl-bsp-release)

- Weston 1.6

- Kernel 3.10.53 (linux-imx)

- gpu-viv: 5.0.11.p4.3

 

New configuration:

- Yocto Jethro (community)

- Weston 1.8/1.9 (tried both, same result)

- Kernel 3.14.38 (linux-imx) / 3.14.52 (nitrogen)

- gpu-viv: 5.0.11.p7.4 / 5.0.11.p8.3

 

 

Any pointers would be welcomed. Thanks!

 

--

Dominique

Outcomes