AnsweredAssumed Answered

Cannot boot from eMMC i.mx6UL EVK

Question asked by Jacob Bower on Sep 29, 2015
Latest reply on Sep 30, 2015 by Jacob Bower

I have an i.MX6UL-EVK that has had the micro SD card slot removed and an eMMC chip put in its place (MTFC4GACAAAM-4M IT).  The chip is (was) blank. 

I’ve tried loading the board two ways:

I have the L3.14.38_ga_images_MX6UL images.  I used a lauterbach Trace32 to flash the u-boot-imx6ul14x14ddr3arm2_emmc.imx to the eMMC starting at address 0x200.  I then set the boot switches and reboot the board.  I see no output on the debug UART, and after a second or two, the USB HID device shows up if I connect the OTG port to the host PC.

I also tried using the MFGTool.  When using it, the board starts to boot and responds with this:

 

   U-Boot 2015.04-imx_v2015.04_3.14.38_6ul_ga+g5d63276 (Aug 18 2015 - 21:05:16)

CPU:   Freescale i.MX6UL rev1.0 at 396 MHz

CPU:   Temperature 36 C

Reset cause: POR

Board: MX6UL 14X14 DDR3 ARM2

I2C:   ready

DRAM:  1 GiB

force_idle_bus: sda=0 scl=0 sda.gp=0x3 scl.gp=0x2

Can't find PMIC:PFUZE100

initcall sequence bff93d08 failed at call 87802e28 (err=-1)

### ERROR ### Please RESET the board ###

 

As the 6UL-EVK does not have a PMIC, I would expect it to not find one, but I don’t understand why the u-boot images for this reference board would be looking for one in the first place.

In either case, I’m not able to successfully boot the device.

Outcomes