AnsweredAssumed Answered

Init_FB FB_TA_b pin not setup

Question asked by Adrian Rockall on May 12, 2015
Latest reply on Jun 19, 2015 by Marek Neuzil

Hi,

 

I have created a project in KDS3.0 + KSDK 1.2 and added the Init_FB component. I have setup all the options as they should be including defining the TA pin but the generated code never initialises the pin multiplexer.

In Driver Suite 10.4 + KSDK 1.1 the pin was setup in Common_Init() along with many others that were already configured in configure_fb_pins(). In KDS 3.0 + KSDK 1.2 the duplicates have been removed from Common_Init along with the TA pin but the TA pin configuration has not been added to the init_fb_pins function.

If I manually add   PORT_HAL_SetMuxMode(PORTC,19UL,kPortMuxAlt6); to init_fb_pins then my board works again.

I have also tried to disable the TA pin in Init_FB and configuring it in PinSettings but still not working.

 

The only problem with me adding it manually is it gets overwritten every time I generate the Processor Expert Code again.

 

I did look at using the new fsl_flexbus component but I couldn't work out how to setup multiple chip select lines as each configuration specifies 1 address space but it appears only one configuration is active?

 

Also Does Chip specify the chip select line?

 

Best regards,

Adrian.

Outcomes