AnsweredAssumed Answered

Migrating from MQX4.1.1 to 4.1.2_Vybrid - USB issues

Question asked by Sandro Bastos on Dec 17, 2014
Latest reply on Dec 19, 2014 by keno

Hello everybody,

 

Did anyone update MQX 4.1.1 to 4.1.2-Vybrid successfully?

Are there some material about the new USB approach?

 

I'm using IAR and TWR-VF65GS10

 

I'm facing many problems because many things seem to be different.

I built the libs, changed the include paths, etc. without success.

 

Some includes and typedefs changed; for example:

 

USB_ENDPOINTS - doesn't exist anymore;

#include "usb_device_stack_interface.h" - doesn't exist in previous version (4.1.1)

 

I had to use a grep and USB examples to find out where some declarations were, but there are still many errors.

 

I wonder there should be an easy and smart way to migrate without so much effort.

 

thanks and best regards

sandro

 

Karina Valencia Aguilar

Bruno Castelucci

Rene Kolarik

Robson Costa

David Seymour

Outcomes