AnsweredAssumed Answered

Video recording pipelines that work with tvsrc on iMX6 GStreamer

Question asked by mad strum on Oct 14, 2014
Latest reply on Mar 8, 2015 by shengqiang ai

Hi,

 

Trying to record video via tvsrc through the adv7180, using imx6quad, using the freescale multimedia libraries.

So far I'm only able to get the following pipelines to work reliably on endurance runs of 15-30min:

 

gst-launch -e tvsrc ! vpuenc codec=6 bitrate=1000000 ! flvmux ! filesink location=output.flv sync=false

gst-launch -e tvsrc ! vpuenc codec=6 bitrate=1000000 ! matroskamux ! filesink location=output.mkv sync=false

 

Have tried mp4mux, qtmux and avimux, but these give me various errors.

I'm particularly interested in avimux as my colleague mostly work in windows and with virtualdub. However, when I subsitute avimux in place of flvmux or matroskamux, the video is corrupted. When I try to play it back it is extremely jittery, as if it were playing at 1fps. Taking out vpuenc in the pipeline for avimux (recording raw video) causes the video to be corrupted as well. See greenish stuff, and no video content.

 

I've also tried using queue , queue2 and multiqueue in the pipeline but they didn't make much of a difference in my video output.

 

Have anyone got  avimux to work with a similar setup?

Outcomes