AnsweredAssumed Answered

First impression with KDS 1.1.0 Can't Debug FRDM-K64F with OpenOCD/CMSIS-DAP

Question asked by schen on Aug 10, 2014
Latest reply on Nov 15, 2014 by Bilal Arain

Just installed KDS 1.1.0.

 

Wrote a simple program using Processor Expert to blink an LED.

I tried an FRDM-KL25Z. It works with OpenOCD/CMSIS-DAP and OpenSDA/P&E GDB Server.

 

I tried an FRDM-K64F. Was able to get it to work with OpenOCD/Segger J-Link firmware but can't get it to go into debugger with OpenOCD/CMSIS-DAP.

I tried the latest firmware 20140530_k20dx128_k64f_if_mbed.bin. It displayed these messages in the Console then went silent:

OpenOCD failed 2.jpg

When I manually switched to Debug perspective, I see this:

OpenOCD failed 3.jpg

 

I tried an older version of the firmware: DEBUG_K64F_MBED_PEMICRO_V108.bin, which gave me the following error:

FRDM-K64F OpenOCD failed.jpg

 

When I tried DEBUG-FRDM-K64F_Pemicro_v108.bin firmware, it would not communicate with P&E GDB Server.

OpenSDA failed.jpg

 

Any suggestions are appreciated.

Outcomes