AnsweredAssumed Answered

How to have OpenMP available on Yocto for iMX6?

Question asked by maurice on Jul 17, 2014
Latest reply on Oct 9, 2014 by maurice



I have the the official release from Freescale to use Yocto. I created a sdk cross-toolchain by the command 'bitbake linux-imx -c populate-sdk' then I launched the script in tmp/deploy/sdk. Version of poky used is 1.5.3.

However, I want to use OpenMP in this cross-toolchain.

By default, the option of openMP is disable hence I modified  these recipes to comment the "--disable libgomp" :

  • sources/poky/meta/recipes-core/gettext/
  • sources/poky/meta/recipes-devtools/gcc/
  • sources/poky/meta/recipes-devtools/gcc/

Then, after creating  the sdk cross-toolchain, I have his error

"...i686-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/../../libexec/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.8.1/ld: error:  hello uses VFP register arguments, ./libgomp.a(parallel.o) does not

... i686-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/../../libexec/arm-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.8.1/ld: failed to merge target specific data of file ./libgomp.a(parallel.o)"


Indeed, I need to use the option "-mfloat-abi=hard".

How can I do that?


Thank you