AnsweredAssumed Answered

CW 10.6  flash programmer problem

Question asked by Walter Muth on Jun 11, 2014
Latest reply on Jun 23, 2014 by Walter Muth

Hello,

 

I have a working code (.S19 file -SH32 ) and tried to program it with the flash programmer under CW 10.6 . Before we used CW 6.3 (classical) and we had no problem. We used the hiwave.exe debugger.If  I use the "flash to target" under 10.6 all seems to be ok. But there seems to be a problem with the baudrate of the serial port of the MCU(1200bd). I get only garbled characters back. It looks like there is something wrong with the MCU clock. I tried version 10.3,10.4, 10.6 with the same results. There is no problem flashing the .s19 file with "hiwave.exe" of CW 6.3.

Programming adapter used  " P&E Multilink Universal"

 

Here is log file under 10.6

 

fl::target -lc "LC for Simple Flash"

fl::target -b 0x80 0x400

fl::target -v off -l off

cmdwin::fl::device -d "MC9S08SH32_FLASH" -o "32kx16x1" -a 0x8000 0xffff

cmdwin::fl::image -f "C:\\Users\\walter\\Downloads\\treg232\\treg232.s19" -t "Auto Detect" -re on -r 0x8000 0xffff -oe off

cmdwin::fl::erase image

  Beginning Operation ...   

-------------------------

Auto-detection is successful.  

   File is of type Motorola S-Record Format.  

 

Performing target initialization ...   

Device MC9S08SH32_FLASH   

Detect frequence ...  

Frequence 7980.27 Khz  

  Erasing ..............

Erase Command Succeeded.  

Device MC9S08SH32_FLASH   

cmdwin::fl::write

-------------------------

Flash Operation.  ...

Auto-detection is successful.  

   File is of type Motorola S-Record Format.  

 

Device MC9S08SH32_FLASH   

  Programming ...................

Device MC9S08SH32_FLASH   

Program Command Succeeded   

Flash Operation. done  

 

Any idea ?

 

Regards

 

Walter

Outcomes