Hi Freescale
When I boot form emmc, sometime failed to mount sata disk in kernel.
That's failed to mount sata debug message from kernel.
##########################################################################
ata1: SATA link down (SStatus 1 SControl 300)
ata1: exception Emask 0x10 SAct 0x0 SErr 0x4040000 action 0xe frozen t4
ata1: irq_stat 0x00000040, connection status changed
ata1: SError: { CommWake DevExch }
ata1: hard resetting link
ata1: SATA link down (SStatus 1 SControl 300)
ata1: EH complete
EXT3-fs: barriers not enabled
kjournald starting. Commit interval 5 seconds
EXT3-fs (mmcblk0p1): warning: maximal mount count reached, running e2fsck is recommended
EXT3-fs (mmcblk0p1): using internal journal
EXT3-fs (mmcblk0p1): recovery complete
EXT3-fs (mmcblk0p1): mounted filesystem with writeback data mode
VFS: Mounted root (ext3 filesystem) on device 179:1.
Freeing init memory: 192K
##########################################################################
Sometime will be success to mount sata disk.
That's success to mount sata disk message.
##########################################################################
ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
mmcblk0: p1
mmcblk0boot1: unknown partition table
sgtl5000 4-000a: sgtl5000 revision 17
mmcblk0boot0: unknown partition table
ata1.00: ATA-8: Hitachi HTS545016B9A300, PBBOC60F, max UDMA/133
ata1.00: 312581808 sectors, multi 0: LBA48 NCQ (depth 31/32)
ata1.00: configured for UDMA/133
scsi 0:0:0:0: Direct-Access ATA Hitachi HTS54501 PBBO PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 312581808 512-byte logical blocks: (160 GB/149 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
asoc: sgtl5000 <-> imx-ssi.1 mapping ok
sda: sda1
sd 0:0:0:0: [sda] Attached SCSI disk
##########################################################################
Thanks
Clayder