AnsweredAssumed Answered

FRDM-K64F Startup problems

Question asked by Ed Sutter on May 30, 2014
Latest reply on Jun 3, 2014 by Ed Sutter

Hi, I'm trying to get started with the FRDM-K64F board.

I've played with mbed; but would prefer to just use cygwin/gcc and build the apps that come with the SDK.

 

So, I unzipped the sdk, and cd'd to apps/hello_world/gcc/frdmk64f120m .  I adjusted the common.mk file

(at the top directory level) to point to my arm-none-eabi-gcc.  When I typed make, I get an error like this:

 

arm-none-eabi-gcc.exe: error: /cygdrive/c/users/ed/documents/KinetisK64/Kinetis_SDK/KSDK_1.0.0-Beta/apps/hello_world/src/hello_world.c: No such file or directory

 

Of course, the file does exist but (I've seen this before) apparently arm-none-eabi-gcc.exe doesn't understand the "/cygdrive/c" path which is created by abspath in the makefile.

So, I tried to hard-code the path to use C:/ instead of /cygdrive/c, then 'make' complains with this error:

 

c:/users/ed/documents/KinetisK64/Kinetis_SDK/KSDK_1.0.0-Beta/mk/targets.mk:149: *** target pattern contains no '%'.

 

Googling a bit, I found that newer versions of make don't like the colon in the path, so the recommendation (according to

stackoverflow) was to use make version 3.8.  So I build it and replace my current make (which was GNU Make 4.0).

Then when I run with that version of make, its apparently so old that it doesn't recognize "else ifeq" in some of the other

  1. makefiles.  Arrgghh!

 

I must be doing something wrong here right?  Has anyone built the SDK apps using cygwin/gcc?

Tx

Ed

Outcomes