AnsweredAssumed Answered

Timer example not working for timer value in micro seconds on MQX 3.6.1 MCF52259evb

Question asked by Pradeep Verma on May 20, 2014
Latest reply on May 20, 2014 by Pradeep Verma

Hi All,

 

I am not able to invoke a timer function that has a granularity of microseconds. I tried using following original code

   _timer_create_component(TIMER_TASK_PRIORITY, TIMER_STACK_SIZE);

 

 

   _time_init_ticks(&dticks, 0);

   _time_add_sec_to_ticks(&dticks, 2);

 

 

   _time_get_elapsed_ticks(&ticks);

   _time_add_sec_to_ticks(&ticks, 1);

   on_timer = _timer_start_periodic_at_ticks(LED_on, 0,

      TIMER_ELAPSED_TIME_MODE, &ticks, &dticks);

   _time_add_sec_to_ticks(&ticks, 1);

   off_timer = _timer_start_periodic_at_ticks(LED_off, 0,

      TIMER_ELAPSED_TIME_MODE, &ticks, &dticks);

 

I tried by invoking the api _time_add_usec_to_ticks & all other parameters remaining the same. Kindly help me out with the things that I am missing out for the desired result of a periodic timer at 100 microseconds(say)

 

Best Regards,

Outcomes