AnsweredAssumed Answered

Mainline u-boot with custom i.mx28 board fails to boot

Question asked by semihhazar on Mar 24, 2014
Latest reply on Apr 5, 2014 by semihhazar
Branched to a new discussion

Hi All,

 

Our custom i.mx28 board fails to boot via USB Recovery Mode. I've used Yocto to build a toolchain (arm-poky-linux-gnueabi 4.8.1) and created a new board for u-boot, compiled and created the u-boot.sb file.

 

Using mxsldr to transfer the sb file I see HTLLCLLC on the debug console and then the board resets, goes back to recovery mode.

 

I've enabled CONFIG_SPL_SERIAL_SUPPORT and put in a few serial_puts in spl code and it seems SPL stage is running without any problems. I also wrote a very basic DDR test code which writes and reads data from memory and there seems to be no problems.

 

To track the error I've placed a debug("!") at the beginning of board_init_f function (assuming this is the earliest place I can test) but I see no output. I also tried lighting up one of the LEDs, but that didn't work either. So I'm assuming second stage is not running at all?

 

I also tried m28evk_config and it behaves exactly, but spits out an 'Undefined Ins' before going to reset.

 

What else can I check?

Outcomes