AnsweredAssumed Answered

What's the difference between arm-linux- / arm-none-linux-gnueabi- / arm-fsl-linux-gnueabi- in LTIB?

Question asked by Ed Sutter on Oct 1, 2013
Latest reply on Mar 25, 2014 by syed ahmed

Showing off my stupidity yet again I suppose...

 

I'm on a SABRESD board with linux running (LTIB).  I wanted to write a simple "hello-world.c"

to make sure I used the correct tools.  So I built it with arm-fsl-linux-gnueabi-gcc (under /opt/freescale), moved it

to my embedded system and it worked as expected.  To further test, I built it again using arm-none-linux-gnueabi-gcc

figuring that it would not run, but it worked.

Then I did a quick ls -l on the bin directory and I see that two different named toolsets all linked to arm-fsl-linux-gnueabi-xxx

under /opt/freescale; giving a total of three different named gcc toolsets all pointing to the same executable.

 

What's up with that?  The bare-metal tools have to use different libs than the linux-user-space tools right?

Is this done internally based on argv[0] or something?

Ed

Outcomes