AnsweredAssumed Answered

Dead links in LTIB install

Question asked by jcpep on Jun 7, 2013
Latest reply on Aug 6, 2013 by Yuri Muhin

Hello,

 

I am currently trying to install LTIB on my Ubuntu 12.10, to compile a kernel for my Freescale iMX6 Sabre Lite. But the fails of several packages keeps on failing: the urls of the packages from the website bitshrine.org respond with a 404 error. For tar.gz archives, it's no big deal, as I can download them and put them on my /opt/freescale/pkgs/ folder. But now the ltib script is trying to retrieve a patch file, which I can't download. Here is the host_config.log file for this error:

Processing: flex
==================
Build path taken because: no prebuilt rpm,
Try flex-2.5.37-1355511909.patch.md5 from the PPP
wget: unable to resolve host address `auslxsc01.am.freescale.net'
Try flex-2.5.37-1355511909.patch.md5 from the GPP
http://bitshrine.org/gpp//flex-2.5.37-1355511909.patch.md5:
2013-06-07 11:19:39 ERROR 404: Not Found.
Try flex-2.5.37-1355511909.patch from the PPP
wget: unable to resolve host address `auslxsc01.am.freescale.net'
Try flex-2.5.37-1355511909.patch from the GPP
http://bitshrine.org/gpp//flex-2.5.37-1355511909.patch:
2013-06-07 11:19:40 ERROR 404: Not Found.
Can't get: flex-2.5.37-1355511909.patch at ./ltib line 802.
Died at ./ltib line 1392.
traceback:
  main::build_host_rpms:1392
   main::host_checks:1447
    main:554
 
 
Started: Fri Jun  7 11:19:38 2013
Ended:   Fri Jun  7 11:19:40 2013
Elapsed: 2 seconds

These packages failed to build:
flex
 
Build Failed

 

Is this a known issue? Is there a workaround to this (like another website where the packages and patches would be hosted)?

Outcomes