AnsweredAssumed Answered

xvimagesink0: Could not initialise Xv output

Question asked by Javier Rodriguez on Jan 3, 2013
Latest reply on Jan 22, 2013 by Javier Rodriguez
Branched to a new discussion

Hi there!

 

I am a really newbie freescale user and I am getting an issue with the videosink element in gstreamer.

 

I am using a iMX6Q Sabrelite with a Ubuntu 12.09 within.

 

I have modified the v4l2 kernel module in order to detect the Logitech c920 Webcam. This webcam is able to capture video with H264 hardware in HD (1080p). With a program I have captured the raw NALs into a file.

 

Now, I can reproduce the video using the vpu decoder. The video plays smoothly and the system is using less than 10% of the CPU. It works fine but the gstreamer is using the v4l_sink by default. This sink puts the video directly within the framebuffer device so the system draws the image on the desktop without using a window. This is a real problem because I am working on an application that uses this and I need to display the video in a window.

 

I have tried to use the "xvimagesink" instead of "autovideosink" but I got this error:

 

$ gst-launch-0.10 filesrc location=test.h264 ! h264parse ! vpudec ! xvimagesink

 

Setting pipeline to PAUSED ...

ERROR: Pipeline doesn't want to pause.

ERROR: from element /GstPipeline:pipeline0/GstXvImageSink:xvimagesink0: Could not initialise Xv output

Additional debug info:

xvimagesink.c(1428): gst_xvimagesink_get_xv_support (): /GstPipeline:pipeline0/GstXvImageSink:xvimagesink0:

No port available

Setting pipeline to NULL ...

Freeing pipeline ...

 

It is very extrange. I have installed all xorg modules thate using the Xv but it does still not working.

 

If I execute the command xvinfo, I get this:

 

X-Video Extension version 2.2

screen #0

no adaptors present

 

What do you think about it?.


Thank you very much.

Outcomes