AnsweredAssumed Answered

MfgTool Error

Question asked by Kevin Cody on Dec 17, 2012
Latest reply on Apr 18, 2013 by robb zimmerman

Hello,

 

I am running into an error when attempting to run the manufacturing tool on my laptop.  The dialog box that appears indicates that there is a runtime error in the Microsoft Visual C++ Runtime Library.

 

This error appears regardless of what version of the manufacturing tool I am using.  I have tried running version 1.6.2.032 and version 1.6.2.042.  I initially tried uninstalling and reinstalling the Microsoft Visual C++ 2008 Redistributable (Runtime Libraries) but the error still appears.  I then downloaded the source files for MfgTool version 1.6.2.048.  Initially I was having the same problem as above when running the tool in Debug.  I was able to make a change so that now the program loads, but when I select the Options menu and the Configuration… menu item and the MfgTool-Configuration window appears I select the USB Ports tab.   An unhandled exception then occurs indicating exception at 0x76ee15de in MfgTool.exe:0xC0000005: Access violation reading location 0x00000024.

 

I have traced the issue down to the following code in the UsbController.cpp file that makes a call to DeviceIoControl:

 

success     = DeviceIoControl(hController, IOCTL_USB_GET_ROOT_HUB_NAME,
                              &unicodeName, sizeof(unicodeName), &unicodeName,
                              sizeof(unicodeName), &bytesReturned, NULL);

 

The first three times that this function is called it seems to work fine, and the unicodeName structure contains what appear to be valid values.  A value of 1 is also returned, but the fourth time this is called DeviceIoControl returns a value of 0, and the unicodeName structure appears to contain garbage.  A
call to GetLastError returns a value of 1.  According to Windows system error code documentation an error code of 1 is ERROR_INVALID_FUNCTION.  From my understanding this is due to using a CTL_CODE that is not supported in the driver.  The description of the driver being called is: USB-IF xHCI USB Host Controller.  I don’t see this as an installed device driver on my laptop when looking at device manager.  The laptop I have is a DELL Latitude E6530.

 

Has anyone experienced this problem before?  The manufacturing tool works on all of the other laptops here in the building, but I am the only
one I know of with a latptop this new.

 

Thanks,

 

Kevin

 

Outcomes