sabrelite with kernel 3.10.17

cancel
Showing results for 
Search instead for 
Did you mean: 

sabrelite with kernel 3.10.17

2,178 Views
Senior Contributor I

Now using yocto I added the freesclae-release-bsp so I can compile the 3.10.17, also for sabrelite. (adding PREFERRED_VERSION and PREFERREd PROVIDER to local.conf).

But when i configure MACHINE=imx6qsabrelite then i try to bit bake any image. I try to compile several packets (e.g uboot) but when it try tp compile uboot i have an error:

soc.c: In function 'v7_outer_cache_enable':

| soc.c:527:24: error: 'CONFIG_SYS_PL310_BASE' undeclared (first use in this function)

|    (struct pl310_regs *)CONFIG_SYS_PL310_BASE;

|                         ^

| soc.c:527:24: note: each undeclared identifier is reported only once for each function it appears in

| soc.c: In function 'v7_outer_cache_disable':

| soc.c:535:24: error: 'CONFIG_SYS_PL310_BASE' undeclared (first use in this function)

|    (struct pl310_regs *)CONFIG_SYS_PL310_BASE;

|                         ^

| make[1]: *** [soc.o] Error 1

but when i bitbake the same but with MACHINE = imx6qsabresd it compiles with no error... something wrong on some CONFIGDEFINES I think... Any ideas?

Thanks

Omar

21 Replies

8 Views
Senior Contributor I

Now with Master next I was able to bitbake core-image minimal...

But there are something missing in deploy:

imx6q-sbrelite.dtb is not copied to boot directory with dd of .sdcard file. so I copied "by hand".

and after that I had to dd the exte separately... but could be a problem of my usb to SD adapter..

then it boots.

Omar

0 Kudos

8 Views
Senior Contributor II

Hi Omar,

If you're using master-next, you can use MACHINE=nitrogen6x to build for SABRE Lite. You may need to be explicit about the provider and version in your local.conf:

PREFERRED_PROVIDER_virtual/kernel = "linux-boundary"

PREFERRED_PROVIDER_u-boot = "u-boot-boundary"

PREFERRED_VERSION_linux-boundary = "3.10.17"

0 Kudos

8 Views
Senior Contributor I

sorry I'm making a lot of confusiont to myself to....

We started working with sabreSD , then we made some prototype with sabrelite due to space restriction.

And now we are building the prototype of our first board (custom one), but now I was still working with sadrelite.

I will read

Sorry if i make so much consfusion to you, but still i have some problem to full understand the config phase...

Omar

Thanks

0 Kudos

8 Views
Senior Contributor I

I think i will try to shitch to Master-next branch...

probably i have already make this question:

but how can I switch from dora (including meta-fsl-bsp-release  3.10.17 beta: I did http://git.freescale.com/git/cgit.cgi/imx/meta-fsl-bsp-release.git/tree/imx/README?h=dora_3.10.17-1....) to master next?

Omar

0 Kudos

8 Views
Senior Contributor I

Or maybe I culd add the :

https://github.com/boundarydevices/linux-imx6/tree/boundary-imx_3.10.17_1.0.0_beta

in the manifest

And use their git to compile for sabrelite..

What do you think?

0 Kudos

8 Views
NXP Employee
NXP Employee

for sabrelite forget about meta-fsl-bsp-release

Start over using only fsl-bsp-community: Freescale/fsl-community-bsp-platform · GitHub

I told you it's very-very confusing :smileylaugh:

I mean, start a new folder and only copy over your specific changes. It will clean your build enviroment and will free you from a lot of explicit configuration you *for sure* do not  need

8 Views
Senior Contributor I

even with 3.10.17 beta?

0 Kudos

8 Views
Senior Contributor I

I mean i should use master-next? right?

0 Kudos

8 Views
Senior Contributor I

Ok I restarted using just fsl-bspcommunity on master-next branch.

But i think that at the end i will work and build the kernel outside yocto then "import it inside" po pack everything... So i could use any kernel (from fresscale, from boundary etc...)

What do you think?

Omar

0 Kudos

8 Views
NXP Employee
NXP Employee

first of all decide your hardware.

Usually, the kernel provided by freescale does not have sabrelite support. Usually, kernel provided by BD is made over FSL kernel, so you would have support for both sabreSD and sabrelite.

kernel 3.10.17 for sabrelite/nitrogen is on master already:

https://github.com/Freescale/meta-fsl-arm-extra/tree/master/recipes-kernel/linux/linux-boundary-3.10...

Get used with git log and git branches. It will empower you to really understand the source code you´re working with! :smileywink:

8 Views
Senior Contributor I

I tried with master and master-next but there is an error somewhere about mesa:

1) > bitbake fsl-image-test

Parsing recipes: 100% |########################################################################################################################| Time: 00:03:02

Parsing of 1361 .bb files complete (0 cached, 1361 parsed). 1787 targets, 83 skipped, 0 masked, 0 errors.

ERROR: No recipes available for:

  /home/yocto/IMX6_yocto/fsl-community-bsp/sources/meta-fsl-arm/recipes-graphics/mesa/mesa_9.2.2.bbappend

ERROR: Command execution failed: Exited with 1

Summary: There were 2 ERROR messages shown, returning a non-zero exit code

2) even with show receipe:

>bitbake-layers show-recipes

Parsing recipes..ERROR: No recipes available for:

  /home/yocto/IMX6_yocto/fsl-community-bsp/sources/meta-fsl-arm/recipes-graphics/mesa/mesa_9.2.2.bbappend

???

Omar

0 Kudos

8 Views
Senior Contributor I

fixed it:

the name is wrong. the mesa_9.2.2.bbappend MUST be renamed to mesa_9.2.5.bbappend

so

> mv fsl-community-bsp/sources/meta-fsl-arm/recipes-graphics/mesa/mesa_9.2.2.bbappend fsl-community-bsp/sources/meta-fsl-arm/recipes-graphics/mesa/mesa_9.2.5.bbappend

shout i send a patch to master-next?

Omar

8 Views
Senior Contributor I

well... sorry How can i do it.... yes I'm a newby..

8 Views
Senior Contributor I

well now bach to bitabaking fsl-image-test

If i do it for sabrelite I have such erros:

NOTE: Resolving any missing task queue dependencies

ERROR: Nothing RPROVIDES 'cpuburn-neon' (but /home/yocto/IMX6_yocto/fsl-community-bsp/sources/meta-fsl-demos/recipes-fsl/packagegroups/packagegroup-fsl-tools-benchmark.bb RDEPENDS on or otherwise requires it)                                                                                                             

ERROR: cpuburn-neon was skipped: incompatible with machine imx6qsabrelite (not in COMPATIBLE_MACHINE)

NOTE: Runtime target 'cpuburn-neon' is unbuildable, removing...

Missing or unbuildable dependency chain was: ['cpuburn-neon']

NOTE: Runtime target 'packagegroup-fsl-tools-benchmark' is unbuildable, removing...

Missing or unbuildable dependency chain was: ['packagegroup-fsl-tools-benchmark', 'cpuburn-neon']

ERROR: Required build target 'fsl-image-test' has no buildable providers.

Missing or unbuildable dependency chain was: ['fsl-image-test', 'packagegroup-fsl-tools-benchmark', 'cpuburn-neon']                                           

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

If i do that for sabdresd no erros... (well until now is still bitbaking)...

0 Kudos

8 Views
Senior Contributor I

in nitorge6x.conf Ifound the

PREFERRED_VERSION_linux-boundary ?= "3.0.35" so override it in local.conf with

PREFERRED_VERSION_linux-boundary ?= "3.10.17"

but i cannot find the PREFERRED_VERSION_linux-imx_mx6 ?= "3.0.35" some where i think there is a default for imx6qsabresd....

i can override it with PREFERRED_VERSION_linux-imx_mx6 ?= "3.10.17" but was just tounderstand where are the default when PREFERRED is not specified

Omar

0 Kudos

8 Views
NXP Employee
NXP Employee

there is another file with several PREFERRED_XXX: meta-fsl-arm/conf/include/imx-base.inc

8 Views
Senior Contributor I

it's ok, for me... I'm try to "enter" in this new mode.... I would like to contribute....

I found a fix... let me know how to submit it..

Omar

0 Kudos

8 Views
Senior Contributor I

ok, I will!!:smileyhappy:

0 Kudos

8 Views
NXP Employee
NXP Employee

HI Omar! I saw you in meta-freescale!

Do you know kernel 3.10.17 is super fresh, right? It's on beta stage yet. That's why we only have it on master and master-next.

Both branches are for development, that's why you're facing so much errors.

And, we are in that period of the year when yocto project is going to be release, so a lot of work has been doing along these days.

When working on stable branch, this kind of thing does not happen

3.10.17 kernel will be in a stable branch after next yocto project release, in April