mx6 dual display quality

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

mx6 dual display quality

Jump to solution
2,630 Views
Dennis_Han
Contributor II

hi.

I'm using custom board based on sabrelite.

basically, dual display is working fine.

but, fb1 for second display has bad quality issue.

please refer to attached pics.

this is my working bootargs.

setenv bootargs console=ttymxc1,115200 video=mxcfb1:dev=hdmi,1280x720M@60, if=RGB24 video=mxcfb0:dev=hdmi2,1280x720M@60,if=RGB24 fbmem=28M,28M vmalloc=192M, root=/dev/mmcblk0p1 rw rootwait consoleblank=0

i add sil9022 driver as the board designed and changed its name to hdmi2.

all works fine except bad quality.

HDMI ------------------------> fb1

RGB ------->sil9022 -----> fb0

both displays set to ipu 0 disp_id 0.

i think this causing my issue though, i don't know very much about IPU stuff.

i switched fb0 and fb1 to check whether it makes different. though, just same as before.

pleas help me out.

Labels (2)
Tags (2)
0 Kudos
1 Solution
1,515 Views
Dennis_Han
Contributor II

Now I got a solution.

I change hdmi ipu to 1,

now 0 for hdmi2 as in pinmuxed, 1 for hdmi (dynamic while kernel booting).

I still don't know why ipu dropped the bits.

maybe bandwidth issue ?

View solution in original post

0 Kudos
4 Replies
1,516 Views
Dennis_Han
Contributor II

Now I got a solution.

I change hdmi ipu to 1,

now 0 for hdmi2 as in pinmuxed, 1 for hdmi (dynamic while kernel booting).

I still don't know why ipu dropped the bits.

maybe bandwidth issue ?

0 Kudos
1,515 Views
Dennis_Han
Contributor II

root@imx6qsabrelite:~# fbset -i -fb /dev/fb0

mode "1280x720-60"

    # D: 74.250 MHz, H: 45.000 kHz, V: 60.000 Hz

    geometry 1280 720 1280 720 32

    timings 13468 178 56 24 1 136 5

    hsync high

    vsync high

    rgba 8/16,8/8,8/0,8/24

endmode

Frame buffer device information:

    Name        : DISP3 BG

    Address     : 0x18000000

    Size        : 3686400

    Type        : PACKED PIXELS

    Visual      : TRUECOLOR

    XPanStep    : 1

    YPanStep    : 1

    YWrapStep   : 1

    LineLength  : 5120

    Accelerator : No

root@imx6qsabrelite:~# fbset -i -fb /dev/fb2

mode "1280x720-60"

    # D: 74.250 MHz, H: 45.000 kHz, V: 60.000 Hz

    geometry 1280 720 1280 720 32

    timings 13468 220 110 20 5 40 5

    hsync high

    vsync high

    rgba 8/16,8/8,8/0,8/24

endmode

Frame buffer device information:

    Name        : DISP3 BG - DI1

    Address     : 0x18800000

    Size        : 3686400

    Type        : PACKED PIXELS

    Visual      : TRUECOLOR

    XPanStep    : 1

    YPanStep    : 1

    YWrapStep   : 1

    LineLength  : 5120

    Accelerator : No

these are my fb settings for fb0 and fb2.

currently,

fb0 is mapped with hdmi2 (sil9022) -> it shows good quality.

fb1 is overlay for fb0

fb2 is mapped with hdmi (internal hdmi) -> it shows bad quality (seems 16 bit)

anybody any idea ?

0 Kudos
1,515 Views
VladanJovanovic
NXP Employee
NXP Employee

Looks like framebuffer has only 16-bit or less bits per pixel. Is it due to SIL9022 setup or a software config issue?

0 Kudos
1,515 Views
Dennis_Han
Contributor II

HI !!!!

Thanks for the reply.

i swapped the fb order for both to test if the issue is related sii902x driver.

but, when sii902x (hdmi2) to fb0.  it shows good quality.

so with fb0 both  devices has no problem. but, with fb2 the problem arised. (with hdmi, or hdmi2 just same)

i tried bpp=32 option, 1280x720-32 mode string, IPU_PIX_FMT_RGB24 pixel format and V4L2_PIX_FMT_RGB24 for display. and so on.

all of them were not helpful.

is there anyhting i missed ?

0 Kudos