modprobe command not listing all the drivers

cancel
Showing results for 
Search instead for 
Did you mean: 

modprobe command not listing all the drivers

59 Views
Contributor III

We have included the layers of meta-multimedia and appended packages like v4l2 and other video packages to the image. After bitbaking the image, the 'modprobe' command is not listing all the drivers. The main driver that needs to be recognised is the driver for adv7180 listed in the paths of /media/i2c and /media/platform/subdev of the kernel-source directory made during bitbake.

Only one package is being shown i.e., galcore.ko file in the extra folder. Even though the entire driver folder was compiled using make command during bitbaking, the changes are not listed in the root shell of the board OS.

modprobe.png

How to incorporate these changes in the built, or if there a way to use depmod command to list out and add the required drivers?

Labels (3)
0 Kudos
1 Reply

3 Views
NXP TechSupport
NXP TechSupport

Hi Abhijeet

L3.14.61-fslc version is not supported by nxp, one can try with some from

nxp official linux-imx - i.MX Linux kernel  repository

Linux  Documentation
i.MX Software | NXP 


Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos