mfgtool error, device disconnect

cancel
Showing results for 
Search instead for 
Did you mean: 

mfgtool error, device disconnect

151 Views
Contributor II


Hello forum,

we have to use mfgtools to burn a custom kernel,u-boot and rootfs into the board's NAND and the process can't complete because the tool keeps disconnecting the device. It doesn't report failure, but after it loads the initramfs, it starts booting from NAND after "Jumping to OS image". If we burn the vendor's image(no kernel modifications of our own), it works well, we have succeded in replacing the rootfs. If anyone can suggest a way forward?


Mfgtools 2.7
Yocto 2.1
kernel 4.1.15
u-boot 2016.03
board: Myirtech's  MYS-6ULX-IOT (nxp's imx.6ull processor)

Labels (1)
0 Kudos
1 Reply

34 Views
NXP TechSupport
NXP TechSupport

Hi Katerina

for custom board one can try to run ddr test and update Mfg Tool firmware
image with new ddr calibration coefficients found from test
i.MX6/7 DDR Stress Test Tool V3.00 
Update coefficients (example is for i.MX6Q Sabre SD board) in uboot/../mx6sabresd/mx6q_4x_mt41j128.cfg

and then rebuild Mfg Tool firmware (files in  ../firmware folder, fsl-image-mfgtool-initramfs-imx_mfgtools.cpio.gz.

u-boot). For rebuilding use sect.6.2 Manufacturing Tool, MFGTool attached Yocto Guide.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos