ltib configuration to make the FEC interface work

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ltib configuration to make the FEC interface work

1,144 Views
VincentChou1z
Contributor III

Hi! Friends,

I tried to use "MIN" profile to build my u-boot, kernel and rootfs and successfully booted the QSB.  Unfortunately I could not see any eth0 in my "ifconfig" output.  I configure my ltib environment based on the BSP userguide.  Could anyone share the way to configure the ltib to make my u-boot and kernel access the FEC interface successfully?  I appreciate any suggestion!

Vincent

Labels (1)
0 Kudos
9 Replies

842 Views
RandyKrakora
NXP Employee
NXP Employee

Sorry - I never use the gnome profile, always only min profile. Or I start with an Ubuntu image and add to it.

Maybe you forgot a setting in the "Target System Configuration"? Or maybe the gnome profile startup doesn't use the "Target System Configuration" settings?

0 Kudos

843 Views
VincentChou1z
Contributor III

Hi!  Randy, I observed one strange phenomenon.  If I build the freescale gnome release in ltib, I discovered that the eth0 cannot be activated even I set up the ethernet MAC address (ethaddr) within u-boot.  However, I could make eth0 work if I set ethaddr within u-boot when I use MIN profile.  Any hints on what I do wrong?

Vincent

0 Kudos

843 Views
RandyKrakora
NXP Employee
NXP Employee

Yes, I forgot about that step. I've had to program an ethernet address in some boards that do not have one...not sure if they all are blank, but I know 1-2 boards I have used I had to program one in. Good job!

0 Kudos

843 Views
VincentChou1z
Contributor III

I discovered that my problem originates from that I did not set ethaddr in my u-boot environment and then cause the system does not have a hardware MAC address.  Now I have already fixed it.  Thanks for the help!

0 Kudos

843 Views
VincentChou1z
Contributor III

Hi!  Randy,

I follow your steps but still can only get LO from ifconfig command.  Somehow eth0 always failed even I just enable eth0 for my system configuration.  Any place I should look into?

0 Kudos

843 Views
VincentChou1z
Contributor III

Should I still set up different u-boot environment parameters even though I have configured the IP setting with ltib?

0 Kudos

843 Views
RandyKrakora
NXP Employee
NXP Employee

Min Profile, I always use that one.

0 Kudos

843 Views
VincentChou1z
Contributor III

Could you tell me which profile you used to build this configuration?

0 Kudos

842 Views
RandyKrakora
NXP Employee
NXP Employee

All I did was go into "Target System Configuration" and selected "start networking", then went under "Network setup" and made sure interface 0 was enabled, set the IP, etc. and it came up when I booted the kernel.

0 Kudos