imx8mq: m4 blocks when using i2c, spi in android

cancel
Showing results for 
Search instead for 
Did you mean: 

imx8mq: m4 blocks when using i2c, spi in android

374 Views
edward_fu
Contributor III

Hi,

I am facing a problem when m4 using i2c and spi resources in Android(bootmcu && boota mmc0), m4 will block.

But if I just run m4 at uboot(only bootmcu), it runs OK.

And also m4 runs OK, if m4 does not use i2c or spi resources in Android(bootmcu && boota mmc0).

I am sure I have disabled i2c and spi resources and pinmux in linux kernel device tree(imx8mq-evk.dts). 

So what's the possible reason? Am I missing any configurations(RDC or clock configurations)?In my opinion, m4 will run OK if resource will not conflict between m4 and linux.

Thanks .

Edward

 

Labels (1)
0 Kudos
4 Replies

360 Views
AldoG
NXP TechSupport
NXP TechSupport

Hello,

You're correct, you need to disable the peripherals that it would be used by M4 when running Cortex-A and Cortex-M at the same time.

Please check that in your code you're not using other peripherals. Also, please note that you'll need to reserve UART2, since it is used by the Cortex-M by default for terminal.

Best regards,
Aldo.

0 Kudos

348 Views
edward_fu
Contributor III

Thanks.

I'd like to know how to disable peripherals in A53, in other words, how to configure RDC in A53.

Br

Edward

0 Kudos

336 Views
AldoG
NXP TechSupport
NXP TechSupport

Hello,

You may refer to the RDC SDK example located at:
<sdk_path>\boards\evkmimx8mq\driver_examples\rdc

Best regards,
Aldo.

0 Kudos

327 Views
edward_fu
Contributor III

I know what you mean. There is no need to configure RDC module in linux kernel? Where and how to configure RDC module in linux kernel.

Thanks

Br,

Edward

0 Kudos