imx6qsabre development board image

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6qsabre development board image

636 Views
Contributor II

HI,

I'm trying to run the imx6qsabresd image on the dev board and get the following on boot:

------------------------------------------------------------------------------------------------------

U-Boot 2014.07-00136-gf870252 (Sep 22 2014 - 09:16:34)

CPU:   Freescale i.MX6Q rev1.2 at 792 MHz

Reset cause: POR

Board: SABRE Lite

I2C:   ready

DRAM:  1 GiB

MMC:   FSL_SDHC: 0, FSL_SDHC: 1

SF: Detected SST25VF016B with page size 256 Bytes, erase size 4 KiB, total 2 MiB

*** Warning - bad CRC, using default environment

No panel detected: default to HDMI

Display: HDMI (1024x768)

In:    serial

Out:   serial

Err:   serial

Net:   using phy at 6

FEC [PRIME], usb_ether

Hit any key to stop autoboot:  0

AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode

flags: ncq stag pm led clo only pmp pio slum part

No port device detected!

** Bad device size - sata 0 **

SATA device 1: unknown device

** Bad device sata 1 **

MMC: no card present

MMC: no card present

** Bad device mmc 0 **

switch to partitions #0, OK

mmc1 is current device

reading /6x_bootscript

** Unable to read file /6x_bootscript **

(Re)start USB...

USB0:   lowlevel init failed

USB1:   USB EHCI 1.00

scanning bus 1 for devices... 2 USB Device(s) found

       scanning usb for storage devices... 0 Storage Device(s) found

       scanning usb for ethernet devices... 0 Ethernet Device(s) found

USB device 0: unknown device

** Bad device usb 0 **

USB device 1: unknown device

** Bad device usb 1 **

6x_bootscript not found

serial console at 115200, 8N1

details at http://boundarydevices.com/6q_bootscript

AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode

flags: ncq stag pm led clo only pmp pio slum part

No port device detected!

AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode

flags: ncq stag pm led clo only pmp pio slum part

No port device detected!

MMC: no card present

switch to partitions #0, OK

mmc1 is current device

expose mmc drive 1 over USB

UMS: disk start sector: 0x0, count: 0x3d4800

-

------------------------------------------------------------------------------------------------------

The image I flashed on the sd is:

fsl-image-qt5-imx6qsabresd-20151026135231.rootfs.sdcard

which i created using :

MACHINE=imx6qsabresd source fsl-setup-release.sh -b build-qfb -e x11

bitbake fsl-image-gui

when booting with the provided sd which has the timesys on it, it loads fine so there board seems to be OK.

also it seems to look for uImage but the build creates a zImage for the kernel. is there a configuration to change it?

thanks.

Labels (5)
Tags (1)
0 Kudos
3 Replies

138 Views
NXP TechSupport
NXP TechSupport

Hi shlomi

from log seems this is "Board: SABRE Lite", while image

for another board : Sabre SD "imx6qsabresd". For Sabre Lite board

images one can look at

https://boundarydevices.com/imx6-builds/

Timesys Getting Started Guide for element14 Board Built to Freescale SABRE Lite Design | Timesys Emb...

O.S. Board Image Provider

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

138 Views
Contributor II

thanks,

I created an sd image from the timesys setup and now the kernel is stuck on "Starting kernel...":

U-Boot 2014.07-00136-gf870252 (Sep 22 2014 - 09:16:34)

CPU:   Freescale i.MX6Q rev1.2 at 792 MHz

Reset cause: POR

Board: SABRE Lite

I2C:   ready

DRAM:  1 GiB

MMC:   FSL_SDHC: 0, FSL_SDHC: 1

SF: Detected SST25VF016B with page size 256 Bytes, erase size 4 KiB, total 2 MiB

No panel detected: default to HDMI

Display: HDMI (1024x768)

In:    serial

Out:   serial

Err:   serial

Net:   using phy at 6

FEC [PRIME], usb_ether

Hit any key to stop autoboot:  1

    0

U-Boot >

U-Boot > echo $loadaddr

echo $loadaddr

0x12000000

U-Boot > echo $fdt_addr

echo $fdt_addr

0x18000000

U-Boot >  bootm ${loadaddr} - ${fdt_addr}

bootm ${loadaddr} - ${fdt_addr}

## Booting kernel from Legacy Image at 12000000 ...

   Image Name:   Linux-3.10.17-ts-armv7l

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    4864216 Bytes = 4.6 MiB

   Load Address: 10008000

   Entry Point:  10008000

   Verifying Checksum ... OK

## Flattened Device Tree blob at 18000000

   Booting using the fdt blob at 0x18000000

   Loading Kernel Image ... OK

   Using Device Tree in place at 18000000, end 1800e84a

Starting kernel ...

0 Kudos

138 Views
NXP TechSupport
NXP TechSupport
0 Kudos