imx6qp qt5 wayland dual screen display with g2d first bluescreen problem in yocto bsp 4.1.15-2.1.0-ga

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6qp qt5 wayland dual screen display with g2d first bluescreen problem in yocto bsp 4.1.15-2.1.0-ga

657 Views
mrleo
Contributor IV

Hi,all

      I configure imx6qp with g2d can display two screen normal in weston clone mode. like below:

     # /etc/init.d/weston stop

     # weston --tty=1 --use-g2d=1 --device=/dev/fb0,/dev/fb2 --clone-mode --log=/var/log/weston.log

    

      I found if I configure weston two screen display with g2d ,first will found blue screen ,later display the weston lauch.

 And the weston cannot lockscreen and standby.

       If I configure weston single screen display with gl,the --idle-time=300,default 5min,start the weston ,first is black screen,later is display the weston lauch.5minute later will lockscreen,screen off .

Why configure weston display with g2d,first start the weston will found blue screen,not black screen,this is not good for me.And configure idle-time is not valid.

Anyone can help me solve this problem or give me some advices?

Thanks,

Leo

3 Replies

262 Views
adorable
Contributor III

If you view the weston codes,you will find the reason of blue screen: in raw codes of ./libweston/g2d_renderer.c,all .clrcolor=0xFF400000;

I change the value to 0x0(means black).

0 Kudos

271 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Leo,

Did you resolved this issue? I see this question as assumed answered but I wanted to double check and if you solved this issue it would benefit our communities if you could share your findings.

Regards,

0 Kudos

266 Views
adorable
Contributor III

Hi gusarambula :

    I have also mit the bulue screan problom with use_g2d=1 in my project。

Have you solved this problom and shared the method?

0 Kudos