imx6qp GUI hang | IPU issue

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6qp GUI hang | IPU issue

356 Views
arunkumar_ev
Contributor II

Hello team,

setup:

We are having a custom board based on imx6qp with 4G DDR. On software side we are using yocto with kernel 4.14.78 and xfce desktop environment. The board is booting successfully and we can observe GUI on HDMI display.

Issue:

On running glmark2 or graphic based application, after few seconds GUI is stuck. But we can still access the board from console and perform read/write operations. Resolution was 1920x1080 on HDMI while running glmark2. We tried reducing the resolution to 640x480, this just delays the issue. Eventually the GUI is stuck with lower resolution as well.

Query:

In kernel we are using imx6qp.dts with all prg and pre nodes enabled, frame buffer node enabled with prefetch. We are using imx6qp-sabreauto.dts as reference. Any checkpoint regarding this issue? Is this a known issue with this kernel or was it later rectified in other version?

Please let us know if you need additional information

Thanks & Regards,

Arun Kumar

Labels (1)
Tags (4)
0 Kudos
4 Replies

265 Views
gianlucarenzi71
Contributor II

I am having the same issue related with a iMX6QP with latest Linux kernel 4.19.144 and Debian Buster (with added Freescale firmware blob). The GUI hangs after 7/8 minutes with OpenGL (glmark2 and Qt 5.11 EGLFS), no matter if I am using the HDMI output or the LVDS output port.

Is there something to check even if I have not Yocto Installed???

The same distribution and software runs fine with iMX6DL processor (it has not the IPU...)

 

Regards,

Gianluca

0 Kudos

271 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Arun

what bsp used in the case, may be recommended to try one from nxp

official source.codeaurora.org/external/imx/linux-imx  repository

linux-imx - i.MX Linux kernel 

Linux L4.14.78_1.0.0 Documentation

Try to reproduce issue on i.MX6QP Sabre SD reference board with

Linux Binary Demo Files - i.MX 6QuadPlus, i.MX 6Quad, i.MX 6DualPlus, i.MX 6Dual, i.MX 6DualLite, i....


Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

271 Views
arunkumar_ev
Contributor II

Hello Igor,

We are using yocto sumo release 4.14.78 for imx6 from NXP.

Release manifest - imx_4.14.78_1.0.0_ga.xml

Thanks & Regards,

Arun Kumar

0 Kudos

271 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Arun

to narrow down problem (if it is hardware or software) one can try to reproduce issue on i.MX6QP Sabre SD reference board with

Linux Binary Demo Files - i.MX 6QuadPlus, i.MX 6Quad, i.MX 6DualPlus, i.MX 6Dual, i.MX 6DualLite, i....

Best regards
igor

0 Kudos