imx6dl: blank screen while xorg server starting

cancel
Showing results for 
Search instead for 
Did you mean: 

imx6dl: blank screen while xorg server starting

737 Views
parthitce
Contributor II

Board Information:

Board: Santaro Core x2

Soc: i.MX6Dual

Graphics: GC320 Vivante

Software Information:

Linux kernel: 4.14.26

Yocto: rocko release + meta-freescale (MACHINE = use-mainline-bsp)

Xorg Driver: xf86-video-armada (with etnaviv-source from https://github.com/laanwj/etna_viv.git)

Requirement:

I have used lzopcat to dump logo image into fb0 during the early phase of booting. Once all the applications are started, I am trying to start xorg server and chromium after that. Here the screen goes black for ~6 to 10 seconds before chromium appears on screen.

I wanted to achieve seamless splash logo during this phase.

What I have tried:

I have tried patching (Google Groups ) for modesettings and tried using framebuffer based with "-background none" to xorg server.

I have tried started xorg server with armada driver + background none option.

From the code I could see that the xf86-video-armada doesn't have implementation for "backgroun none" option to copy/retain the framebuffer content during xorg start up phase (correct me if I am wrong).

 

Should I need to patch Linux Kernel IPU to avoid the screen going blank?

Problem:

  1. How can I achieve seamless logo display in this case? Please suggest.
  2. Chromium consumes more then 80% of CPU all the time. Am I missing something for acceleration? Please suggest. How can I accelerate chromium?
  3. How can I achieve the splash screen from u-boot to chromium?

I am happy to have alpha blending transition from logo to chromium display without any blank screen if possible.

My xorg.conf:

Section "Device"
Identifier "Driver0"
Screen 0
Driver "armada"

# Support hotplugging displays?
Option "Hotplug" "TRUE"

# Support hardware cursor if available?
Option "HWCursor" "TRUE"

# Use GPU acceleration?
Option "UseGPU" "TRUE"

# Provide Xv interfaces?
Option "XvAccel" "TRUE"

# Prefer overlay for Xv (TRUE for armada-drm, FALSE for imx-drm)
Option "XvPreferOverlay" "TRUE"

# Which accelerator module to load (automatically found if commented out)
Option "AccelModule" "etnadrm_gpu"
Option "AccelModule" "etnaviv_gpu"

# Support DRI2 interfaces?
Option "DRI" "TRUE"
EndSection

Thanks in advance for your help and suggestion.

Thanks,

Parthiban N

0 Kudos
1 Reply

152 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Parthiban

linux kernel: 4.14.26 is not supported by nxp, one can try with L4.1.15

linux-imx - i.MX Linux kernel 

use sect.5.6.6 Chromium Browser attached Yocto Guide and sect.17.3.5 xorg.conf for i.MX 6

Linux Manual. Splashscreen patch:

https://community.nxp.com/docs/DOC-98109 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos