iMX53 linux 2.6.8, serial console problem

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX53 linux 2.6.8, serial console problem

Jump to solution
838 Views
cyrilcrocquesel
Contributor II

Hi,

For accessing max98088 driver, i try to update my iMX53 QSB from a linux 2.6.35.3 to a linux 2.6.38.

To do it I've changed my setting in ltib to use a 2.6.38 linux. I update the source by downloading the last release (12.01.01).

It compiled successfully but, at runtime, I lose my serial console (UART 1) after "Uncompressing kernel... done, booting the kernel.".

To upload the new rootfs and uImage, I use MfgTool with the same config as before (I just changed rootfs.tar.bz2 and uImage).

Cordially

Cyril CROCQUESEL

0 Kudos
1 Solution
228 Views
cyrilcrocquesel
Contributor II

Hi,

I find the solution :

IMX serial support was not selected in kernel option

also console on IMX serial port

Now I have an other problem but this one is solve.

Thanks

Cyril

View solution in original post

0 Kudos
4 Replies
228 Views
cyrilcrocquesel
Contributor II

I've made a mistake, the uImage was not the good one.

No I get the next error : bad command from bootm. And I arrived on a prompt : "MX53-LOCO-BIN>"

I will make some test tomorrow And give the result

Cordially

Cyril

Updated at 04/04/2013 9:36 (GMT+1) :

Hi,

I success to boot the kernel with the following command :

MX53-LOCO U-Boot > setenv bootargs_base 'setenv bootargs console=ttymxc0,115200'

MX53-LOCO U-Boot > setenv bootargs_mmc 'setenv bootargs ${bootargs} root=/dev/mmcblk0p1 rootwait rw video=mxcdi1fb:GBR24,VGA-XGA di1_primary vga'

MX53-LOCO U-Boot > setenv bootcmd_mmc 'run bootargs_base bootargs_mmc;mmc dev 0;mmc read ${loadaddr} 0x800 0x1800;bootm'

MX53-LOCO U-Boot > setenv bootcmd 'run bootcmd_mmc'

MX53-LOCO U-Boot > saveenv

MX53-LOCO U-Boot > run bootcmd

But I have again no more information in the serial console after this message :

"Uncompressing kernel... done, booting the kernel."

The kernel start, at least, until the VGA start-up. (I can display the linux logo on the screen).

Cordially,

Cyril

0 Kudos
228 Views
matthiasniederm
Contributor II

Hi Cyril,

do you have enabled kernel output? Maybe your kernel is on a quiet boot. You can change the settings by modifying "menuconfig -> kernel hacking"

Cheers

MaTT

228 Views
cyrilcrocquesel
Contributor II

Hi,

I add in kernel option for kernel low level debug and also early printk. But this doesn't change the behavior at boot.

Would you like I join my .config file?

Cordially

Cyril

0 Kudos
229 Views
cyrilcrocquesel
Contributor II

Hi,

I find the solution :

IMX serial support was not selected in kernel option

also console on IMX serial port

Now I have an other problem but this one is solve.

Thanks

Cyril

View solution in original post

0 Kudos