i.mx53 Flashing

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

i.mx53 Flashing

263 Views
aliunsal
Contributor I

Hi everyone,

I am working with TX53-8030 device on TX Mainboard. 

TX53-8030 has i.mx535 processor as main CPU. I downloaded mfgtools flash tool program from https://www.nxp.com/products/processors-and-microcontrollers/arm-processors/i-mx-applications-proces... . I just installed the driver of the board and I run the MFGTOOLS program. 

Recognised my device but cannot to flash. 

aliunsal_0-1715683841780.png

 

How can I flash i.mx53 with MFGTOOLS.

OS: Windows 7 64Bit

 

Thanks for all

Labels (1)
0 Kudos
4 Replies

245 Views
JorgeCas
NXP TechSupport
NXP TechSupport

Hello,

 

I suggest you take a look on this link.

 

Also, please make sure to use bitbake fsl-image-mfgtool-initramfs to build the manufacturing image.

 

Best regards.

0 Kudos

223 Views
aliunsal
Contributor I

Hi, 

 

Thank you for reply. I don't know how about using the Yocto. I know and use buildroot before.

Can I use mfgtools and buildroot?

0 Kudos

214 Views
JorgeCas
NXP TechSupport
NXP TechSupport

Hello,

As is mentioned on the document, you need to build a manufacturing image since this Linux will talk to the mfg. tool during reprogramming and only mentions how to do it with Yocto.

Best regards.

0 Kudos

92 Views
aliunsal
Contributor I

It's not solution for me. I have already an kernel image for ready to boot. But I don't know how can I boot this images to the imx53.

MFGTool does not progress when I start the boot processes. I checked the Serial bus to see if I could see the u-boot output, but there is no output while u-boot.

I want to create a bootable SD card but I have not a SPL file in the output of the buildroot. 

 

0 Kudos