i.MX6UL HAB

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX6UL HAB

292 Views
ranjithhebbar
Contributor II

Dear all,

 

     I am working on i.MX6UL based custom board. Booting SPL and u-boot-ivt.img normally.

     In HAB case, we signed SPL image and u-boot-ivt.img we tested in Open mode gives "NO HAB Event Found" Message for Authentication. Then we tried HAB closed mode.

   

     In HAB  closed mode, SPL signed image and u-boot-ivt.img signed image will work successfully. And according to document corrupting signed images like SPL-signed-pad.bin and u-boot-signed.img will not boot as expected.

    But Normal images are booting SPL and u-boot-ivt.img (which is not signed) without any error in HAB closed mode. Is this behavior expected in HAB? I am just wondering why normal images are booting..!!!! ?

Best Regards,

Ranjith Hebbar

Labels (3)
0 Kudos
2 Replies

98 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  Some HAB features are described in section 4.1.1 (SRK HASH and HAB events in open mode)

of app note AN4581, Rev. 2, 05/2018.

  

https://www.nxp.com/docs/en/application-note/AN4581.pdf 

Regards,

Yuri.

0 Kudos

98 Views
art
NXP TechSupport
NXP TechSupport

Yes, this is the expected behaviour. An unsigned image boots successfully even in HAB enabled mode.


Have a great day,
Artur

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos