i.MX51 Android BSP make Error

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MX51 Android BSP make Error

186 Views
HitoshiOgasawar
Contributor III

Dear Sir,

I'm having problems with an error of Android BSP of "i.MX51" and "make" run.

The patched the "R10.3", we have to "R10.3.1" Android BSP.

Error occurs is as follows.

Please tell me someone an idea to solve this.

+++

hardware/alsa_sound/AudioHardwareALSA.cpp:349: error: 'DEVICE_OUT_WIRED_HDMI' is not a member of 'android::AudioSystem'

hardware/alsa_sound/AudioHardwareALSA.cpp: In member function 'virtual android::AudioStreamIn* android::AudioHardwareALSA::openInputStream(uint32_t, int*, uint32_t*, uint32_t*, android::status_t*, android::AudioSystem::audio_in_acoustics)':

hardware/alsa_sound/AudioHardwareALSA.cpp:397: error: 'DEVICE_OUT_WIRED_HDMI' is not a member of 'android::AudioSystem'

make: *** [out/target/product/imx51_bbg/obj/SHARED_LIBRARIES/libaudio_intermediates/AudioHardwareALSA.o] Error 1

+++

Best Regards,

Jin.

Labels (1)
Tags (2)
0 Kudos
4 Replies

86 Views
YixingKong
Senior Contributor IV

Hitoshi

This discussion is closed since no activity. If you still need help, please feel free to reply with an update to this discussion, or create another discussion.

Thanks,

Yixing

0 Kudos

86 Views
YixingKong
Senior Contributor IV

Hitoshi

We have not got your response yet and will close the discussion in 3 days. If you still need help, please feel free to reply with an update to this discussion.

Thanks,

Yixing

0 Kudos

86 Views
YixingKong
Senior Contributor IV

Hitoshi

Had your issue got resolved? If yes, we are going to close the discussion in 3 days. If you still need help, please feel free to reply with an update to this discussion.

Thanks,

Yixing


0 Kudos

86 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello,hitoshi,

     I tested R10.3/R10.3.1, But I didn't reproduce the issue you met.

     The final android BSP version we released for i.mx51 & i.mx53 is R10.4 , whose android version is ver2.3.7. This version is stable. So I suggest you had better use R10.4 for your design.

Regards,

Weidong

0 Kudos