how to switch from X11 to Frame buffer

cancel
Showing results for 
Search instead for 
Did you mean: 

how to switch from X11 to Frame buffer

740 Views
niranjanbc
Contributor IV

what changes i need to make in yocto recipes/configuration to switch from X11 to Frame buffer.

currently we are facing some screen lockup issue due to X11.

we would like to switch to frame buffer.

0 Kudos
5 Replies

273 Views
niranjanbc
Contributor IV

I am using krogoth branch

i did like below and built the image. 

PACKAGECONFIG_DISTRO += " eglfs"
DISTRO_FEATURES_remove = " x11 wayland"

when i run application like below i get a error

root@hs:~# QT_QPA_PLATFORM="eglfs" App_demo

QEglFSVivIntegration will set environment variable FB_MULTI_BUFFER=2 to enable d

ouble buffering and vsync.

If this is not desired, you can override this via: export QT_EGLFS_IMX6_NO_FB_M

ULTI_BUFFER=1

Could not open egl display

Aborted

0 Kudos

273 Views
turker
Contributor IV

Assuming fb0 is your main display, try the command below:

echo 32 > /sys/class/graphics/fb0/bits_per_pixel

I could not find the original thread where I found this information. Credit to the original poster.

0 Kudos

273 Views
niranjanbc
Contributor IV

I tried echo 32, it didnt change bits_per_pixel

0 Kudos

273 Views
niranjanbc
Contributor IV

i tried echo 32 > /sys/class/graphics/fb0/bits_per_pixel

i dont see anything change in display

0 Kudos

273 Views
turker
Contributor IV

You need to remove x11 from DISTRO_FEATURES. You may also have to remove packages depending on x11 from the image recipe if it is not done automatically.

0 Kudos