display flickers during startup

cancel
Showing results for 
Search instead for 
Did you mean: 

display flickers during startup

78 Views
Contributor I

Hello,

I am using iMX6QuadPlus processor with TFT display. The designed board for display meets all electrical and timing requirements on the datasheet. The display flickers at start-up and reset time for 1-2 seconds then works fine. Below is the oscilloscope image including data enable, clock and data signals. The area between cursors belongs time of flickering state. Is there any way to deactive data enable signal?  I guess it's about to modules before Display Interface block of IPU but I couldn’t find what can cause this problem. 

Glad if you help me

Regards,

Celile

Labels (2)
0 Kudos
2 Replies

10 Views
NXP TechSupport
NXP TechSupport

Hi Celile

>Is there any way to deactive data enable signal?

one can try to set necessary level in plugin :

plugin.S\mx6sabresd\freescale\board - uboot-imx - i.MX U-Boot 

Also may be recommended to check display power up sequence

defined in its datasheet. One can consider below patches;

https://community.nxp.com/docs/DOC-98109 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

10 Views
Contributor I

Hi,

Sorry for the late reply. The problem has solved when display pin configurations moved from BSP to DI module in system load. Thank you for your help

0 Kudos