compilation error for "iw" tools

cancel
Showing results for 
Search instead for 
Did you mean: 

compilation error for "iw" tools

575 Views
susangracerapak
Contributor II

Hi,

I am compiling iw tools for IMX6 Android Marshmallow. I am getting the following error.

Please , anyone help me to fix this?

root@cpu331:~/myandroid/external/iw-android# mm
============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=6.0.1
TARGET_PRODUCT=sabresd_6dq
TARGET_BUILD_VARIANT=user
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a-neon
TARGET_CPU_VARIANT=cortex-a9
TARGET_2ND_ARCH=
TARGET_2ND_ARCH_VARIANT=
TARGET_2ND_CPU_VARIANT=
HOST_ARCH=x86_64
HOST_OS=linux
HOST_OS_EXTRA=Linux-3.13.0-24-generic-x86_64-with-Ubuntu-14.04-trusty
HOST_BUILD_TYPE=release
BUILD_ID=2.1.0-ga-rc2
OUT_DIR=out
============================================
No private recovery resources for TARGET_DEVICE sabresd_6dq
make: Entering directory `/home/test/myandroid'
target thumb C: iw <= external/iw-android/iw.c

No private recovery resources for TARGET_DEVICE sabresd_6dq
make: Entering directory `/home/test/myandroid'
target thumb C: iw <= external/iw-android/iw.c
external/iw-android/iw.c:28:33: error: conflicting types for 'nl_socket_alloc'
 static inline struct nl_handle *nl_socket_alloc(void)

external/iw-android/iw.c:33:20: error: conflicting types for 'nl_socket_free'
 static inline void nl_socket_free(struct nl_sock *h)

external/iw-android/iw.c:40:25: error: too few arguments to function 'genl_ctrl_alloc_cache'
  struct nl_cache *tmp = genl_ctrl_alloc_cache(h);

external/iw-android/iw.c: In function 'error_handler':
external/iw-android/iw.c:234:46: warning: unused parameter 'nla' [-Wunused-parameter]
 static int error_handler(struct sockaddr_nl *nla, struct nlmsgerr *err,

make: *** [out/target/product/sabresd_6dq/obj/EXECUTABLES/iw_intermediates/iw.o] Error 1
make: Leaving directory `/home/test/myandroid'

#### make failed to build some targets (1 seconds) ####

Regards
Susan

0 Kudos
6 Replies

152 Views
susangracerapak
Contributor II

Hi @chandrasekhar mattaparthy,

My android source code is  android_M6.0.1_2.1.0_source.tar.gz

jdk version is 7 (openjdk-7-jdK)

Ubuntu 16.04 LTS 64-bit Operating System



Regards

Susan

0 Kudos

152 Views
chandrasekharma
Contributor III

Hi susangracerapaka‌,

Please try to build without root because if you are in root you may get build errors in android project.

check the permissions of each and every project. If it it root please change using "sudo chown -R <username> <username> <project/foldername>"

Regards,

CHANDRASEKHAR

152 Views
susangracerapak
Contributor II

Hi CHANDRASEKHAR,

Thanks for the response.

I have tried this, still I am getting the same issue?

Do you have any idea?

Regards

Susan

0 Kudos

152 Views
chandrasekharma
Contributor III

Hi susangracerapaka‌,

Whether you installed establish environment packages to build android please try to install supporting packages by using command "

sudo apt-get install git-core gnupg flex bison gperf build-essential zip curl zlib1g-dev gcc-multilib g++-multilib libc6-dev-i386 lib32ncurses5-dev x11proto-core-dev libx11-dev lib32z-dev ccache libgl1-mesa-dev libxml2-utils xsltproc unzip

Still If you are facing problem give me some time to analyse and let you confirm

Thanks,

CHANDRASEKHAR

0 Kudos

152 Views
susangracerapak
Contributor II

Hi chandrasekharmattaparthy‌,

Thanks for the quick response,

I have installed all these packages before Downloading the Android Image and updated again.Not yet resolved,

Regards

Susan

0 Kudos

152 Views
chandrasekharma
Contributor III

Hi susangracerapaka‌,

Can you please provide your android source code version with tag and host platform version and jdk version

I am unable to see project "iw-android" in 6.0.1_r10. Is this aosp project or nxp patch?

Regards,

CHANDRASEKHAR

0 Kudos