bitbake build failed error code '1'

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

bitbake build failed error code '1'

Jump to solution
21,306 Views
redwill
Contributor II

1. trying to build by "bitbake fsl-image-validation-imx"
but meet error:
ERROR: Task (/home/.../imx-yocto-bsp/sources/poky/meta/recipes-graphics/vulkan/vulkan_1.0.65.2.bb:do_compile) failed with exit code '1'

2. trying to build by "bitbake core-image-minimal"
but meet error:
ERROR: Task (/home/.../imx-yocto-bsp/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-graphics/opencv/opencv_4.0.1.imx.bb:do_compile) failed with exit code '1'

#Note: I'd try these building and success weeks ago..., how can i solve these error

0 Kudos
1 Solution
21,290 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello

 

This errors is happened because you need to setting up your host, for ubuntu 18:

https://www.yoctoproject.org/docs/latest/brief-yoctoprojectqs/brief-yoctoprojectqs.html

 

Regards

 

 

View solution in original post

0 Kudos
5 Replies
21,302 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello redwill,

 

You have to erase everything from the carpet build, and rebuild again the yocto, also make sure that you are posting well the distro and machine of the build.

 

Regards

 

0 Kudos
21,298 Views
redwill
Contributor II

Build Configuration:
BB_VERSION = "1.38.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "ubuntu-18.04"
TARGET_SYS = "aarch64-poky-linux"
MACHINE = "imx8mqevk"
DISTRO = "fsl-imx-wayland"
DISTRO_VERSION = "4.14-sumo"
TUNE_FEATURES = "aarch64"
TARGET_FPU = ""


| aarch64-poky-linux-libtool: link: aarch64-poky-linux-g++ --sysroot=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0=/usr/src/debug/v4l-utils/1.12.3-r0 -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot= -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot-native= -fvisibility-inlines-hidden -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -pthread -o cec-compliance cec-compliance.o cec-test.o cec-test-adapter.o cec-test-audio.o cec-test-power.o -lrt -pthread
| make[3]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-compliance'
| Making all in cec-follower
| make[3]: Entering directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-follower'
| ../../../v4l-utils-1.12.3/utils/cec-ctl/msg2ctl.pl 2 ../../../v4l-utils-1.12.3/include/linux/cec.h ../../../v4l-utils-1.12.3/include/linux/cec-funcs.h >cec-table.h
| aarch64-poky-linux-g++ --sysroot=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot -DHAVE_CONFIG_H -I. -I../../../v4l-utils-1.12.3/utils/cec-follower -I../.. -I../../../v4l-utils-1.12.3/lib/include -Wall -Wpointer-arith -D_GNU_SOURCE -I../../../v4l-utils-1.12.3/include -O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0=/usr/src/debug/v4l-utils/1.12.3-r0 -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot= -fdebug-prefix-map=/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/recipe-sysroot-native= -fvisibility-inlines-hidden -c -o cec-follower.o cec-follower.cpp
| aarch64-poky-linux-g++: error: cec-follower.cpp: No such file or directory
| aarch64-poky-linux-g++: fatal error: no input files
| compilation terminated.
| Makefile:556: recipe for target 'cec-follower.o' failed
| make[3]: *** [cec-follower.o] Error 1
| make[3]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils/cec-follower'
| Makefile:468: recipe for target 'all-recursive' failed
| make[2]: *** [all-recursive] Error 1
| make[2]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build/utils'
| ERROR: oe_runmake failed
| Makefile:574: recipe for target 'all-recursive' failed
| make[1]: *** [all-recursive] Error 1
| make[1]: Leaving directory '/home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/build'
| Makefile:501: recipe for target 'all' failed
| make: *** [all] Error 2
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/will/work/imx-yocto-bsp/build-wayland/tmp/work/aarch64-mx8m-poky-linux/v4l-utils/1.12.3-r0/temp/log.do_compile.91419)
ERROR: Task (/home/will/work/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.12.3.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 2268 tasks of which 2267 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
/home/will/work/imx-yocto-bsp/sources/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.12.3.bb:do_compile

0 Kudos
21,291 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello

 

This errors is happened because you need to setting up your host, for ubuntu 18:

https://www.yoctoproject.org/docs/latest/brief-yoctoprojectqs/brief-yoctoprojectqs.html

 

Regards

 

 

0 Kudos
21,278 Views
redwill
Contributor II

Thanks for the help!
The error solved by remove all files and rebuild the image
i guess the root cause are the wrong repo files or utility files under folder "downloads"

0 Kudos
1,700 Views
brijesh9
Contributor I

GETTING BELOW ERROR WHILE USING BITBAKE

followed below document

https://variwiki.com/index.php?title=Yocto_Toolchain_installation&release=mx8-yocto-mickledore-6.1.2...



In file included from ../config.h:125,
| from ../../elfutils-0.170/libelf/elf32_fsize.c:31:
| ../../elfutils-0.170/libelf/libelfP.h:47:30: error: ‘__elf32_msize’ specifies less restrictive attribute than its target ‘elf32_fsize’: ‘const’ [-Werror=missing-attributes]
| 47 | #define __elfw2_(Bits, Name) __elf##Bits##_##Name
| | ^~~~~
| ../../elfutils-0.170/lib/eu-config.h:60:26: note: in definition of macro ‘strong_alias’
| 60 | extern __typeof (name) aliasname __attribute__ ((alias (#name)));
| | ^~~~~~~~~
| ../../elfutils-0.170/libelf/elf32_fsize.c:68:1: note: in expansion of macro ‘local_strong_alias’
| 68 | local_strong_alias (elfw2(LIBELFBITS, fsize), __elfw2(LIBELFBITS, msize))
| | ^~~~~~~~~~~~~~~~~~
| ../../elfutils-0.170/libelf/libelfP.h:52:29: note: in expansion of macro ‘__elfw2_’
| 52 | #define __elfw2(Bits, Name) __elfw2_(Bits, Name)
| | ^~~~~~~~
| ../../elfutils-0.170/libelf/elf32_fsize.c:68:47: note: in expansion of macro ‘__elfw2’
| 68 | local_strong_alias (elfw2(LIBELFBITS, fsize), __elfw2(LIBELFBITS, msize))
| | ^~~~~~~
| gcc -D_GNU_SOURCE -DHAVE_CONFIG_H -DLOCALEDIR='"/home/brijesh/var-fsl-yocto/build_xwayland/tmp/work/x86_64-linux/elfutils-native/0.170-r0/recipe-sysroot-native/usr/share/locale"' -I. -I../../elfutils-0.170/libelf -I.. -I. -I../../elfutils-0.170/libelf -I../../elfutils-0.170/lib -I.. -isystem/home/brijesh/var-fsl-yocto/build_xwayland/tmp/work/x86_64-linux/elfutils-native/0.170-r0/recipe-sysroot-native/usr/include -std=gnu99 -Wall -Wshadow -Wformat=2 -Wold-style-definition -Wstrict-prototypes -Wlogical-op -Wduplicated-cond -Wnull-dereference -Wimplicit-fallthrough=5 -Werror -Wunused -Wextra -Wstack-usage=262144 -D_FORTIFY_SOURCE=2 -isystem/home/brijesh/var-fsl-yocto/build_xwayland/tmp/work/x86_64-linux/elfutils-native/0.170-r0/recipe-sysroot-native/usr/include -O2 -pipe -c -o elf32_getphdr.o ../../elfutils-0.170/libelf/elf32_getphdr.c
| In file included from ../../elfutils-0.170/libelf/elf32_fsize.c:35:
| ../../elfutils-0.170/libelf/libelfP.h:48:28: note: ‘__elf32_msize’ target declared here
| 48 | #define elfw2_(Bits, Name) elf##Bits##_##Name
| | ^~~
| ../../elfutils-0.170/libelf/libelfP.h:53:27: note: in expansion of macro ‘elfw2_’
| 53 | #define elfw2(Bits, Name) elfw2_(Bits, Name)
| | ^~~~~~
| ../../elfutils-0.170/libelf/elf32_fsize.c:43:1: note: in expansion of macro ‘elfw2’
| 43 | elfw2(LIBELFBITS, fsize) (Elf_Type type, size_t count, unsigned int version)
| | ^~~~~
| cc1: all warnings being treated as errors
| make[2]: *** [Makefile:712: elf64_fsize.o] Error 1
| make[2]: *** Waiting for unfinished jobs....
| cc1: all warnings being treated as errors
| make[2]: *** [Makefile:712: elf32_fsize.o] Error 1
| make[1]: *** [Makefile:478: all-recursive] Error 1
| make: *** [Makefile:394: all] Error 2
| ERROR: oe_runmake failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_compile (log file is located at /home/brijesh/var-fsl-yocto/build_xwayland/tmp/work/x86_64-linux/elfutils-native/0.170-r0/temp/log.do_compile.145440)
ERROR: Task (virtual:native:/home/brijesh/var-fsl-yocto/sources/poky/meta/recipes-devtools/elfutils/elfutils_0.170.bb:do_compile) failed with exit code '1'

0 Kudos