android_kk4.4.2 Boot issue

cancel
Showing results for 
Search instead for 
Did you mean: 

android_kk4.4.2 Boot issue

176 Views
rkp
Contributor I

Hi,

I want to run android_kk4.4.2 in my imx6Q (MCIMX6Q-SDP) demo board. When I tried to boot from my SD card

with pre-built image (android_kk4.4.2_1.0.0-ga_full_image_6qsabresd - downloaded from freescale site) , the boot process was unable to complete and booted till  the "android" logo

and then it is stuck after that.

Please put your suggestions.

NOTE: I have used an 8GB SD card formatted as per the android user guide in freescale site.

please help me to fix this problem.

Labels (2)
0 Kudos
4 Replies

28 Views
haoranwang
NXP Employee
NXP Employee

Hi Roopesh,

     I think your android booting is stopping on the framework issue.

     Please connect the USB<->UART wire to your PC and provide the log from console.

     If possible you can type in "logcat -v time" and copy the logcat of Android for debugging.

Thanks

BRs,

Haoran

0 Kudos

28 Views
SergioSolis
NXP Employee
NXP Employee

Hello Roopesh,

Can you share the log so I can see where did it stop exactly?.  Did you flash your SD card with manufacturing tool or did you do it manually?

0 Kudos

28 Views
rkp
Contributor I

Hi SerchMX,


Thanks for your interest.

I used the following command to download the image to SD card. The SD card was partitioned using mksdcard-android.sh /dev/sdb

sudo dd if=u-boot-6q.bin of=/dev/sdb bs=1K skip=1 seek=1; sync
sudo dd if=boot.img of=/dev/sdb1; sync
sudo dd if=system.img of=/dev/sdb5; sync
sudo dd if=recovery.img of=/dev/sdb2; sync

As the board stuck at android logo during boot up , I didn't get any error logs or messages.

Also I have configured the board ( SW6) according to the user guide.
MMC2(SD3) boot - (SW6) 01000010


Regards,

Roopesh

0 Kudos

28 Views
saurabh206
Senior Contributor III

Hi Roopesh

You follow Android_Quick_Start_Guide.pdf.

User Freescale MFG tool to prepare SD Card.

Thanks

Saurabh

0 Kudos