android 4.4.2 u disk issue !

cancel
Showing results for 
Search instead for 
Did you mean: 

android 4.4.2 u disk issue !

686 Views
liyu1
Contributor III

Hi all :

 

    I found  Android 4.4.2 some U disk counld not mount, But some U disk could mount ! I don't know the reason !

     When I plug in the U disk, reported these message, :

  kernel can see the device !


<6>usb 2-1.4: new high speed USB device number 9 using fsl-ehci

<6>scsi3 : usb-storage 2-1.4:1.0

<5>scsi 3:0:0:0: Direct-Access     Mass     Storage Device   1.00 PQ: 0 ANSI: 0 CCS

<5>sd 3:0:0:0: [sda] 3887104 512-byte logical blocks: (1.99 GB/1.85 GiB)

<5>sd 3:0:0:0: [sda] Write Protect is off

<7>sd 3:0:0:0: [sda] Mode Sense: 03 00 00 00

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<6> sda: sda1

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<5>sd 3:0:0:0: [sda] Attached SCSI removable disk

But app can't ,and report the message


     init: no such service 'fuse_udisk‘ !

     who can tell how to Solve it !

Labels (3)
0 Kudos
5 Replies

148 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi li

issue may be caused by weak/noisy usb signal caused

by board noise or improper layout usb lines, check

IMX6DQ6SDLHDG  sect.3.11 USB recommendations

Please add more filtering on board power supplies and

run usb tests, one can measure eye diagram.

Patch to make i.MX6DQ USB to support test modes for certification test

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

148 Views
liyu1
Contributor III

    If the problem is with USB, could not recognize the device, U disk can be realized in the kernel !

   log :

  

<6>usb 2-1.4: new high speed USB device number 9 using fsl-ehci

<6>scsi3 : usb-storage 2-1.4:1.0

<5>scsi 3:0:0:0: Direct-Access     Mass     Storage Device   1.00 PQ: 0 ANSI: 0 CCS

<5>sd 3:0:0:0: [sda] 3887104 512-byte logical blocks: (1.99 GB/1.85 GiB)

<5>sd 3:0:0:0: [sda] Write Protect is off

<7>sd 3:0:0:0: [sda] Mode Sense: 03 00 00 00

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<6> sda: sda1

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<5>sd 3:0:0:0: [sda] Attached SCSI removable disk

0 Kudos

148 Views
liyu1
Contributor III

Hi :

      my custom board  tested in Android 4.2.2 is no this issue ! But 4.4.2 has !

0 Kudos

148 Views
huangkc
Contributor I

hi li yu and igor:

I have a very similar problem。On andorid4.3,my U disk could  be recognized and receive notification on the systemUI,also is could be mounted.Everything is ok.The log as follow:

usb 2-1: new high speed USB device number 3 using fsl-ehci

scsi1 : usb-storage 2-1:1.0

scsi 1:0:0:0: Direct-Access     Generic- SD/MMC           1.00 PQ: 0 ANSI: 0 CCS

sd 1:0:0:0: [sda] 15523840 512-byte logical blocks: (7.94 GB/7.40 GiB)

sd 1:0:0:0: [sda] Write Protect is off

sd 1:0:0:0: [sda] Mode Sense: 03 00 00 00

sd 1:0:0:0: [sda] No Caching mode page present

sd 1:0:0:0: [sda] Assuming drive cache: write through

sd 1:0:0:0: [sda] No Caching mode page present

sd 1:0:0:0: [sda] Assuming drive cache: write through

sda: sda1

sd 1:0:0:0: [sda] No Caching mode page present

sd 1:0:0:0: [sda] Assuming drive cache: write through

sd 1:0:0:0: [sda] Attached SCSI removable disk

But on andorid4.4.3,The u disk couldn't receive notification on the systemUI  and couldn't be mounted though the U disk could  be recognized. The log as follow:

usb 1-1: new high-speed USB device number 5 using ci_hdrc

usb 1-1: New USB device found, idVendor=0bda, idProduct=0119

usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

usb 1-1: Product: USB2.0-CRW

usb 1-1: Manufacturer: Generic

usb 1-1: SerialNumber: 20090815198100000

usb-storage 1-1:1.0: USB Mass Storage device detected

scsi3 : usb-storage 1-1:1.0

scsi 3:0:0:0: Direct-Access     Generic- SD/MMC           1.00 PQ: 0 ANSI: 0 CCS

sd 3:0:0:0: [sda] 15523840 512-byte logical blocks: (7.94 GB/7.40 GiB)

sd 3:0:0:0: [sda] Write Protect is off

sd 3:0:0:0: [sda] No Caching mode page found

sd 3:0:0:0: [sda] Assuming drive cache: write through

sd 3:0:0:0: [sda] No Caching mode page found

sd 3:0:0:0: [sda] Assuming drive cache: write through

sda: sda1

sd 3:0:0:0: [sda] No Caching mode page found

sd 3:0:0:0: [sda] Assuming drive cache: write through

sd 3:0:0:0: [sda] Attached SCSI removable disk

How do you solve this problem?

0 Kudos

148 Views
liyu1
Contributor III

If the problem is with USB, could not recognize the device, U disk can be realized in the kernel !


   log :



  

<6>usb 2-1.4: new high speed USB device number 9 using fsl-ehci

<6>scsi3 : usb-storage 2-1.4:1.0

<5>scsi 3:0:0:0: Direct-Access     Mass     Storage Device   1.00 PQ: 0 ANSI: 0 CCS

<5>sd 3:0:0:0: [sda] 3887104 512-byte logical blocks: (1.99 GB/1.85 GiB)

<5>sd 3:0:0:0: [sda] Write Protect is off

<7>sd 3:0:0:0: [sda] Mode Sense: 03 00 00 00

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<6> sda: sda1

<3>sd 3:0:0:0: [sda] No Caching mode page present

<3>sd 3:0:0:0: [sda] Assuming drive cache: write through

<5>sd 3:0:0:0: [sda] Attached SCSI removable disk


0 Kudos